summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-02-10 16:35:26 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-02-10 16:35:26 +0000
commitd8de76ea88129cbf87e9b96d107f931e6e85e937 (patch)
tree20c7f3036759367b3b2bc94f5a9a4dce21177c18 /games-action/armagetronad
parentAdded modular X dependencies and closing bug #121359. (diff)
downloadgentoo-2-d8de76ea88129cbf87e9b96d107f931e6e85e937.tar.gz
gentoo-2-d8de76ea88129cbf87e9b96d107f931e6e85e937.tar.bz2
gentoo-2-d8de76ea88129cbf87e9b96d107f931e6e85e937.zip
Added patch to resolve bug #121473.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-action/armagetronad')
-rw-r--r--games-action/armagetronad/ChangeLog6
-rw-r--r--games-action/armagetronad/armagetronad-0.2.7.1.ebuild32
2 files changed, 19 insertions, 19 deletions
diff --git a/games-action/armagetronad/ChangeLog b/games-action/armagetronad/ChangeLog
index 99deeeb5726c..eae6ea580ed7 100644
--- a/games-action/armagetronad/ChangeLog
+++ b/games-action/armagetronad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/armagetronad
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/ChangeLog,v 1.4 2006/02/06 17:39:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/ChangeLog,v 1.5 2006/02/10 16:35:26 wolf31o2 Exp $
+
+ 10 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ armagetronad-0.2.7.1.ebuild:
+ Added patch to resolve bug #121473.
06 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org>
armagetronad-0.2.7.1.ebuild:
diff --git a/games-action/armagetronad/armagetronad-0.2.7.1.ebuild b/games-action/armagetronad/armagetronad-0.2.7.1.ebuild
index 5749770d21cc..4b16958fa9d6 100644
--- a/games-action/armagetronad/armagetronad-0.2.7.1.ebuild
+++ b/games-action/armagetronad/armagetronad-0.2.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1.ebuild,v 1.7 2006/02/06 17:39:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1.ebuild,v 1.8 2006/02/10 16:35:26 wolf31o2 Exp $
inherit flag-o-matic eutils games
@@ -8,7 +8,7 @@ inherit flag-o-matic eutils games
DESCRIPTION="3d tron lightcycles, just like the movie"
HOMEPAGE="http://armagetronad.sourceforge.net/"
SRC_URI="mirror://sourceforge/armagetronad/${P}.tar.bz2
- opengl? (
+ !dedicated? (
http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
http://armagetron.sourceforge.net/addons/moviepack.zip
)"
@@ -16,25 +16,23 @@ SRC_URI="mirror://sourceforge/armagetronad/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE="dedicated opengl"
+IUSE="dedicated"
-RDEPEND="sys-libs/zlib
- opengl? (
+RDEPEND="
+ !dedicated? (
+ sys-libs/zlib
virtual/opengl
+ virtual/glu
media-libs/libsdl
media-libs/sdl-image
- media-libs/sdl-mixer
media-libs/jpeg
media-libs/libpng )"
DEPEND="${RDEPEND}
- app-arch/unzip
- || (
- x11-libs/libX11
- virtual/x11 )"
+ !dedicated? ( app-arch/unzip )"
src_compile() {
filter-flags -fno-exceptions
- if use dedicated && ! use opengl; then
+ if use dedicated; then
egamesconf --disable-glout || die "egamesconf failed"
else
egamesconf || die "egamesconf failed"
@@ -49,18 +47,16 @@ src_install() {
dohtml doc/net/*.html
newicon tron.ico ${PN}.ico
exeinto "${GAMES_LIBDIR}/${PN}"
- if use dedicated && ! use opengl; then
+ if use dedicated; then
doexe src/tron/${PN}-dedicated || die "copying files"
else
doexe src/tron/${PN} || die "copying files"
fi
doexe src/network/armagetronad-* || die "copying files"
insinto "${GAMES_DATADIR}/${PN}"
- if use dedicated && ! use opengl; then
- doins -r log language || die "copying files"
- else
- doins -r arenas models sound textures language log music \
- || die "copying files"
+ doins -r log language || die "copying files"
+ if ! use dedicated; then
+ doins -r arenas models sound textures music || die "copying files"
fi
insinto "${GAMES_SYSCONFDIR}/${PN}"
doins -r config/* || die "copying files"
@@ -69,7 +65,7 @@ src_install() {
fi
cd "${S}"
insinto "${GAMES_DATADIR}/${PN}"
- if use opengl; then
+ if ! use dedicated; then
dogamesbin "${FILESDIR}/${PN}"
insinto "${GAMES_DATADIR}/${PN}"
doins -r ../moviepack ../moviesounds || die "copying movies"