summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-30 16:28:35 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-30 16:28:35 +0000
commit3c3f5d5da6087914d9f5428d2aa41ef3a125a6d9 (patch)
tree12412a629f08bbf391bf61beee2f66b16b1ee717 /dev-vcs
parentRemoved conflict, bug #509168 (diff)
downloadgentoo-2-3c3f5d5da6087914d9f5428d2aa41ef3a125a6d9.tar.gz
gentoo-2-3c3f5d5da6087914d9f5428d2aa41ef3a125a6d9.tar.bz2
gentoo-2-3c3f5d5da6087914d9f5428d2aa41ef3a125a6d9.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tig/ChangeLog7
-rw-r--r--dev-vcs/tig/tig-2.0.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index d80cea73d7ad..2d402df8995e 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.27 2014/01/25 20:43:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.28 2014/04/30 16:28:34 radhermit Exp $
+
+*tig-2.0.1 (30 Apr 2014)
+
+ 30 Apr 2014; Tim Harder <radhermit@gentoo.org> +tig-2.0.1.ebuild:
+ Version bump.
25 Jan 2014; Tim Harder <radhermit@gentoo.org> -tig-1.0.ebuild,
-tig-1.1.ebuild, -tig-1.2.ebuild:
diff --git a/dev-vcs/tig/tig-2.0.1.ebuild b/dev-vcs/tig/tig-2.0.1.ebuild
new file mode 100644
index 000000000000..1e09d21fdf25
--- /dev/null
+++ b/dev-vcs/tig/tig-2.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-2.0.1.ebuild,v 1.1 2014/04/30 16:28:35 radhermit Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="sys-libs/ncurses"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ # pre-generated manpages are in the root directory
+ sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+ econf CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw)"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dohtml manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}