summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-13 21:22:32 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-13 21:22:32 +0000
commitf1a4942490952e830535212ff5e301027fbfe169 (patch)
treeef47e7a06922aa020decf98bc70abb555c2328c7 /dev-vcs/git-sh/git-sh-1.1.ebuild
parentVersion Bump (diff)
downloadgentoo-2-f1a4942490952e830535212ff5e301027fbfe169.tar.gz
gentoo-2-f1a4942490952e830535212ff5e301027fbfe169.tar.bz2
gentoo-2-f1a4942490952e830535212ff5e301027fbfe169.zip
Taken over maintainer ship, moved to EAPI=4
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git-sh/git-sh-1.1.ebuild')
-rw-r--r--dev-vcs/git-sh/git-sh-1.1.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-vcs/git-sh/git-sh-1.1.ebuild b/dev-vcs/git-sh/git-sh-1.1.ebuild
index d59b822a9c18..88cf43268cb8 100644
--- a/dev-vcs/git-sh/git-sh-1.1.ebuild
+++ b/dev-vcs/git-sh/git-sh-1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/git-sh-1.1.ebuild,v 1.1 2011/03/27 15:06:22 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/git-sh-1.1.ebuild,v 1.2 2011/09/13 21:22:32 jlec Exp $
-EAPI="2"
+EAPI=4
-DESCRIPTION="A customized bash environment suitable for git work."
+DESCRIPTION="A customized bash environment suitable for git work"
HOMEPAGE="http://github.com/rtomayko/git-sh"
SRC_URI="http://github.com/rtomayko/${PN}/tarball/${PV} -> ${P}.tar.gz"
@@ -19,18 +19,14 @@ RDEPEND="dev-vcs/git"
S="${WORKDIR}/rtomayko-${PN}-a59681d"
src_prepare() {
- sed -e 's/git-completion\.bash //' \
- -e 's:/local::' -i Makefile || die "sed failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGES README.markdown || die "dodoc failed"
+ sed \
+ -e 's/git-completion\.bash //' \
+ -e 's:/local::' -i Makefile || die "sed failed"
}
pkg_postinst() {
- einfo
+ echo
einfo "For bash completion in git commands emerge dev-vcs/git"
einfo "with bash-completion USE flag."
- einfo
+ echo
}