summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-26 08:48:25 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-26 08:48:25 +0000
commitaab4dde1d78cb32278bef238ab86af06432a05fb (patch)
tree2ecb3ea24abe9fd62f1e7b4127809f9eb7071f66 /dev-vcs/git-cola
parentfix underlinking wrt #429280 (diff)
downloadgentoo-2-aab4dde1d78cb32278bef238ab86af06432a05fb.tar.gz
gentoo-2-aab4dde1d78cb32278bef238ab86af06432a05fb.tar.bz2
gentoo-2-aab4dde1d78cb32278bef238ab86af06432a05fb.zip
dev-vcs/git-cola: Version BUmp
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/ChangeLog7
-rw-r--r--dev-vcs/git-cola/git-cola-1.8.0.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index fe0b4542b8f6..e9833751a149 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.3 2012/05/24 21:19:51 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.4 2012/08/26 08:48:25 jlec Exp $
+
+*git-cola-1.8.0 (26 Aug 2012)
+
+ 26 Aug 2012; Justin Lecher <jlec@gentoo.org> +git-cola-1.8.0.ebuild:
+ Version BUmp
*git-cola-1.7.7-r1 (24 May 2012)
diff --git a/dev-vcs/git-cola/git-cola-1.8.0.ebuild b/dev-vcs/git-cola/git-cola-1.8.0.ebuild
new file mode 100644
index 000000000000..47f7c4ae5202
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-1.8.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.8.0.ebuild,v 1.1 2012/08/26 08:48:25 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="http://git-cola.github.com/"
+SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/jsonpickle
+ dev-python/pyinotify
+ dev-python/PyQt4
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ dev-python/sphinx
+ app-text/xmlto )
+ sys-devel/gettext
+ test? ( dev-python/nose )"
+
+# tests currently broken due to unfinished translation framework
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # don't install docs into wrong location
+ sed -i \
+ -e '/doc/d' \
+ setup.py || die "sed failed"
+
+ sed -i \
+ -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
+ cola/resources.py || die "sed failed"
+
+ epatch \
+ "${FILESDIR}"/1.3.8-disable-tests.patch \
+ "${FILESDIR}"/1.7.7-system-ssh-askpass.patch
+
+ python_convert_shebangs 2 bin/git-cola bin/git-dag
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd share/doc/git-cola/
+ emake all
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc share/doc/git-cola/*.txt
+
+ if use doc ; then
+ dohtml -r _build/html/*
+ doman *.1
+ else
+ dohtml "${FILESDIR}/index.html"
+ fi
+}
+
+src_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
+ --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
+ || die "running nosetests failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/git-cola/lib/cola
+
+ elog "Please make sure you have either a SSH key management installed and activated or"
+ elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
+ elog "Otherwise git-cola may hang when pushing/pulling from remote git repositories via SSH. "
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/git-cola/lib/cola
+}