summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-08-22 19:26:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-08-22 19:26:26 +0000
commitdd7f5bed439f7270a8d384ec9d0164c73ea0896e (patch)
treefb50376fe78ef5475c15777a881207558bc4c88e /dev-util
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-dd7f5bed439f7270a8d384ec9d0164c73ea0896e.tar.gz
gentoo-2-dd7f5bed439f7270a8d384ec9d0164c73ea0896e.tar.bz2
gentoo-2-dd7f5bed439f7270a8d384ec9d0164c73ea0896e.zip
Added 'epatch_user' to ease patch testing.
(Portage version: 2.2.11_p14/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/re2c/ChangeLog5
-rw-r--r--dev-util/re2c/re2c-0.13.7.2.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-util/re2c/ChangeLog b/dev-util/re2c/ChangeLog
index 3a7d90876902..b8fc84d08afb 100644
--- a/dev-util/re2c/ChangeLog
+++ b/dev-util/re2c/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/re2c
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/ChangeLog,v 1.74 2014/07/27 08:42:45 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/ChangeLog,v 1.75 2014/08/22 19:26:26 slyfox Exp $
+
+ 22 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> re2c-0.13.7.2.ebuild:
+ Added 'epatch_user' to ease patch testing.
*re2c-0.13.7.2 (27 Jul 2014)
diff --git a/dev-util/re2c/re2c-0.13.7.2.ebuild b/dev-util/re2c/re2c-0.13.7.2.ebuild
index 18c5541c25c5..44ebc954e030 100644
--- a/dev-util/re2c/re2c-0.13.7.2.ebuild
+++ b/dev-util/re2c/re2c-0.13.7.2.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/re2c-0.13.7.2.ebuild,v 1.1 2014/07/27 08:42:45 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/re2c-0.13.7.2.ebuild,v 1.2 2014/08/22 19:26:26 slyfox Exp $
EAPI=5
+inherit eutils
+
DESCRIPTION="tool for generating C-based recognizers from regular expressions"
HOMEPAGE="http://re2c.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -12,6 +14,10 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+src_prepare() {
+ epatch_user
+}
+
src_compile() {
touch re2c.1 # don't require asciidoc for mans
emake