summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-14 11:45:06 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-14 11:45:06 +0000
commita2eb3f32eefd00ac004e126bf0ea5473ae834792 (patch)
tree09959dd81b2df095fddc88276c66566b48ac05a1 /dev-util
parentStable on ppc wrt bug 221173 (diff)
downloadgentoo-2-a2eb3f32eefd00ac004e126bf0ea5473ae834792.tar.gz
gentoo-2-a2eb3f32eefd00ac004e126bf0ea5473ae834792.tar.bz2
gentoo-2-a2eb3f32eefd00ac004e126bf0ea5473ae834792.zip
Bug #226505 - For compatibity with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/scons/ChangeLog8
-rw-r--r--dev-util/scons/scons-0.97.ebuild9
-rw-r--r--dev-util/scons/scons-0.98.3.ebuild9
-rw-r--r--dev-util/scons/scons-0.98.4.ebuild9
4 files changed, 28 insertions, 7 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index 9de03dc9bd14..2c3edc7b4ba2 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/scons
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.56 2008/05/29 13:41:17 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.57 2008/06/14 11:45:06 zmedico Exp $
+
+ 14 Jun 2008; Zac Medico <zmedico@gentoo.org> scons-0.97.ebuild,
+ scons-0.98.3.ebuild, scons-0.98.4.ebuild:
+ Bug #226505 - For compatibity with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
*scons-0.98.4 (29 May 2008)
diff --git a/dev-util/scons/scons-0.97.ebuild b/dev-util/scons/scons-0.97.ebuild
index 865fa7c1bbbb..3ef736df4115 100644
--- a/dev-util/scons/scons-0.97.ebuild
+++ b/dev-util/scons/scons-0.97.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.97.ebuild,v 1.9 2008/05/13 18:36:19 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.97.ebuild,v 1.10 2008/06/14 11:45:06 zmedico Exp $
NEED_PYTHON="1.5.2"
@@ -24,11 +24,16 @@ src_install () {
mv "${D}"/usr/man "${D}"/usr/share
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.96.92-r1"
+ clean_stale_junk=$?
+}
+
pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/${P}
# clean up stale junk left there by old faulty ebuilds
# see Bug 118022 and Bug 132448
- if has_version "<dev-util/scons-0.96.92-r1" ; then
+ if [[ $clean_stale_junk = 0 ]] ; then
einfo "Cleaning up stale orphaned py[co] files..."
[[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
&& rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
diff --git a/dev-util/scons/scons-0.98.3.ebuild b/dev-util/scons/scons-0.98.3.ebuild
index 9463036d899b..95826a8dc747 100644
--- a/dev-util/scons/scons-0.98.3.ebuild
+++ b/dev-util/scons/scons-0.98.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.3.ebuild,v 1.1 2008/05/13 18:36:19 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.3.ebuild,v 1.2 2008/06/14 11:45:06 zmedico Exp $
NEED_PYTHON="1.5.2"
@@ -24,11 +24,16 @@ src_install () {
mv "${D}"/usr/man "${D}"/usr/share
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.96.92-r1"
+ clean_stale_junk=$?
+}
+
pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/${P}
# clean up stale junk left there by old faulty ebuilds
# see Bug 118022 and Bug 132448
- if has_version "<dev-util/scons-0.96.92-r1" ; then
+ if [[ $clean_stale_junk = 0 ]] ; then
einfo "Cleaning up stale orphaned py[co] files..."
[[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
&& rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
diff --git a/dev-util/scons/scons-0.98.4.ebuild b/dev-util/scons/scons-0.98.4.ebuild
index 42f4bd505a47..2548d77dd372 100644
--- a/dev-util/scons/scons-0.98.4.ebuild
+++ b/dev-util/scons/scons-0.98.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.4.ebuild,v 1.1 2008/05/29 13:41:17 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.4.ebuild,v 1.2 2008/06/14 11:45:06 zmedico Exp $
NEED_PYTHON="1.5.2"
@@ -24,11 +24,16 @@ src_install () {
mv "${D}"/usr/man "${D}"/usr/share
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.96.92-r1"
+ clean_stale_junk=$?
+}
+
pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/${P}
# clean up stale junk left there by old faulty ebuilds
# see Bug 118022 and Bug 132448
- if has_version "<dev-util/scons-0.96.92-r1" ; then
+ if [[ $clean_stale_junk = 0 ]] ; then
einfo "Cleaning up stale orphaned py[co] files..."
[[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
&& rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"