summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-08-21 19:42:36 +0000
committerJohannes Huber <johu@gentoo.org>2014-08-21 19:42:36 +0000
commit14693ddb32fa9e2d96516118ff3f9ed836fee64a (patch)
tree334cd7429cfb3b8ee2ce922ca06feaa64854c337 /dev-util
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-14693ddb32fa9e2d96516118ff3f9ed836fee64a.tar.gz
gentoo-2-14693ddb32fa9e2d96516118ff3f9ed836fee64a.tar.bz2
gentoo-2-14693ddb32fa9e2d96516118ff3f9ed836fee64a.zip
Revision bump adds two upstreams patches. Fix build on fbsd spotted by Yuta SATOH <nigoro@gentoo.gr.jp>, bug #492758. Fix finding Python 3.4 spotted by Jonas Jelten <jonas.jelten@gmail.com>, bug #519522.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog10
-rw-r--r--dev-util/cmake/cmake-2.8.12.2-r2.ebuild203
-rw-r--r--dev-util/cmake/files/cmake-2.8.12.2-fbsd.patch38
-rw-r--r--dev-util/cmake/files/cmake-2.8.12.2-python34.patch34
4 files changed, 284 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 2cd7a180a284..f330a04e9f9b 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.296 2014/08/08 21:22:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.297 2014/08/21 19:42:36 johu Exp $
+
+*cmake-2.8.12.2-r2 (21 Aug 2014)
+
+ 21 Aug 2014; Johannes Huber <johu@gentoo.org> +cmake-2.8.12.2-r2.ebuild,
+ +files/cmake-2.8.12.2-fbsd.patch, +files/cmake-2.8.12.2-python34.patch:
+ Revision bump adds two upstreams patches. Fix build on fbsd spotted by Yuta
+ SATOH <nigoro@gentoo.gr.jp>, bug #492758. Fix finding Python 3.4 spotted by
+ Jonas Jelten <jonas.jelten@gmail.com>, bug #519522.
08 Aug 2014; Agostino Sarubbo <ago@gentoo.org> cmake-2.8.12.2-r1.ebuild:
Stable for sparc, wrt bug #517016
diff --git a/dev-util/cmake/cmake-2.8.12.2-r2.ebuild b/dev-util/cmake/cmake-2.8.12.2-r2.ebuild
new file mode 100644
index 000000000000..466d7a60853e
--- /dev/null
+++ b/dev-util/cmake/cmake-2.8.12.2-r2.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.12.2-r2.ebuild,v 1.1 2014/08/21 19:42:36 johu Exp $
+
+EAPI=5
+
+CMAKE_REMOVE_MODULES="no"
+inherit bash-completion-r1 elisp-common toolchain-funcs eutils versionator cmake-utils virtualx
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="emacs ncurses qt4 qt5"
+
+REQUIRED_USE="?? ( qt4 qt5 )"
+
+DEPEND="
+ >=app-arch/libarchive-2.8.0:=
+ >=dev-libs/expat-2.0.1
+ >=net-misc/curl-7.20.0-r1[ssl]
+ sys-libs/zlib
+ virtual/pkgconfig
+ ncurses? ( sys-libs/ncurses )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}
+ emacs? ( virtual/emacs )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
+ "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
+ "${FILESDIR}"/${PN}-2.8.7-FindLAPACK.patch
+ "${FILESDIR}"/${PN}-2.8.8-FindPkgConfig.patch
+ "${FILESDIR}"/${PN}-2.8.10-darwin-bundle.patch
+ "${FILESDIR}"/${PN}-2.8.10-darwin-isysroot.patch
+ "${FILESDIR}"/${PN}-2.8.10-desktop.patch
+ "${FILESDIR}"/${PN}-2.8.10-libform.patch
+ "${FILESDIR}"/${PN}-2.8.10.2-FindPythonInterp.patch
+ "${FILESDIR}"/${PN}-2.8.10.2-FindPythonLibs.patch
+ "${FILESDIR}"/${PN}-2.8.11-FindBLAS.patch
+ "${FILESDIR}"/${PN}-2.8.11-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.12.1-FindImageMagick.patch
+ "${FILESDIR}"/${PN}-2.8.12.1-FindFreetype.patch
+ "${FILESDIR}"/${PN}-2.8.12.2-hppa-bootstrap.patch
+ "${FILESDIR}"/${PN}-2.8.12.2-FindBoost-python.patch
+ "${FILESDIR}"/${PN}-2.8.12.2-FindCurses.patch
+ "${FILESDIR}"/${PN}-2.8.12.2-fbsd.patch
+ "${FILESDIR}"/${PN}-2.8.12.2-python34.patch
+)
+
+cmake_src_bootstrap() {
+ # Cleanup args to extract only JOBS.
+ # Because bootstrap does not know anything else.
+ echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | tail -n1 | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ # execinfo.h on Solaris isn't quite what it is on Darwin
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/execinfo\.h/blablabla.h/' Source/kwsys/CMakeLists.txt || die
+ fi
+
+ tc-export CC CXX LD
+
+ # bootstrap script isn't exactly /bin/sh compatible
+ ${CONFIG_SHELL:-sh} ./bootstrap \
+ --prefix="${T}/cmakestrap/" \
+ ${par_arg} \
+ || die "Bootstrap failed"
+}
+
+cmake_src_test() {
+ # fix OutDir and SelectLibraryConfigurations tests
+ # these are altered thanks to our eclass
+ sed -i -e 's:#IGNORE ::g' \
+ "${S}"/Tests/{OutDir,CMakeOnly/SelectLibraryConfigurations}/CMakeLists.txt \
+ || die
+
+ pushd "${BUILD_DIR}" > /dev/null
+
+ local ctestargs
+ [[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
+
+ # Excluded tests:
+ # BootstrapTest: we actualy bootstrap it every time so why test it.
+ # CTest.updatecvs, which fails to commit as root
+ # Qt4Deploy, which tries to break sandbox and ignores prefix
+ # TestUpload, which requires network access
+ "${BUILD_DIR}"/bin/ctest ${ctestargs} \
+ -E "(BootstrapTest|CTest.UpdateCVS|Qt4Deploy|TestUpload)" \
+ || die "Tests failed"
+
+ popd > /dev/null
+}
+
+pkg_setup() {
+ # bug 387227
+ addpredict /proc/self/coredump_filter
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # disable running of cmake in boostrap command
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
+ # Add gcc libs to the default link paths
+ sed -i \
+ -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
+ Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
+
+ cmake_src_bootstrap
+}
+
+src_configure() {
+ # make things work with gentoo java setup
+ # in case java-config cannot be run, the variable just becomes unset
+ # per bug #315229
+ export JAVA_HOME=$(java-config -g JAVA_HOME 2> /dev/null)
+
+ local mycmakeargs=(
+ -DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ $(cmake-utils_use_build ncurses CursesDialog)
+ )
+
+ if use qt4 || use qt5 ; then
+ mycmakeargs+=(
+ -DBUILD_QtDialog=ON
+ $(cmake-utils_use_find_package qt5 Qt5Widgets)
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use emacs && elisp-compile Docs/cmake-mode.el
+}
+
+src_test() {
+ VIRTUALX_COMMAND="cmake_src_test" virtualmake
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${PN}.vim"
+
+ dobashcomp Docs/bash-completion/{${PN},ctest,cpack}
+ rm -rf "${D}/usr/share/cmake/completions" || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-2.8.12.2-fbsd.patch b/dev-util/cmake/files/cmake-2.8.12.2-fbsd.patch
new file mode 100644
index 000000000000..ab27af2ec8ca
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.12.2-fbsd.patch
@@ -0,0 +1,38 @@
+From: KWSys Robot <kwrobot@kitware.com>
+Date: Tue, 15 Oct 2013 12:43:32 +0000 (-0400)
+Subject: KWSys 2013-10-15 (6eab64c3)
+X-Git-Tag: v3.0.0-rc1~178^2^2~5
+X-Git-Url: http://cmake.org/gitweb?p=cmake.git;a=commitdiff_plain;h=c01e7445
+
+KWSys 2013-10-15 (6eab64c3)
+
+Extract upstream KWSys using the following shell commands.
+
+$ git archive --prefix=upstream-kwsys/ 6eab64c3 | tar x
+$ git shortlog --no-merges --abbrev=8 --format='%h %s' 96b2f6f4..6eab64c3
+Raphael Kubo da Costa (1):
+ 6eab64c3 SystemInformation: Include backtrace-related headers on FreeBSD
+
+Change-Id: Ib0447aab3d6555ce278f0c1417af2c53e6f181a5
+---
+
+diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation.cxx
+index 7c31f3a..2672730 100644
+--- a/Source/kwsys/SystemInformation.cxx
++++ b/Source/kwsys/SystemInformation.cxx
+@@ -88,6 +88,15 @@ typedef int siginfo_t;
+ # include <ifaddrs.h>
+ # define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
+ # endif
++# if defined(KWSYS_SYSTEMINFORMATION_HAS_BACKTRACE)
++# include <execinfo.h>
++# if defined(KWSYS_SYSTEMINFORMATION_HAS_CPP_DEMANGLE)
++# include <cxxabi.h>
++# endif
++# if defined(KWSYS_SYSTEMINFORMATION_HAS_SYMBOL_LOOKUP)
++# include <dlfcn.h>
++# endif
++# endif
+ #endif
+
+ #if defined(__OpenBSD__) || defined(__NetBSD__)
diff --git a/dev-util/cmake/files/cmake-2.8.12.2-python34.patch b/dev-util/cmake/files/cmake-2.8.12.2-python34.patch
new file mode 100644
index 000000000000..f64e40cc51ef
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.12.2-python34.patch
@@ -0,0 +1,34 @@
+commit ab6201ab647c13fee44c44822b8502e9848faaaf
+Author: Matt McCormick <matt.mccormick@kitware.com>
+Date: Wed Mar 5 17:41:47 2014 -0500
+
+ FindPython{Interp,Libs}: Search for Python 3.4.
+
+ Python 3.4.0rnc1 was released on 2014-02-20.
+
+diff --git a/Modules/FindPythonInterp.cmake b/Modules/FindPythonInterp.cmake
+index 8da848c..e23a58b 100644
+--- a/Modules/FindPythonInterp.cmake
++++ b/Modules/FindPythonInterp.cmake
+@@ -47,7 +47,7 @@ unset(_Python_NAMES)
+
+ set(_PYTHON1_VERSIONS 1.6 1.5)
+ set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
+-set(_PYTHON3_VERSIONS 3.3 3.2 3.1 3.0)
++set(_PYTHON3_VERSIONS 3.4 3.3 3.2 3.1 3.0)
+
+ if(PythonInterp_FIND_VERSION)
+ if(PythonInterp_FIND_VERSION_COUNT GREATER 1)
+diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
+index 0749efc..1dbc967 100644
+--- a/Modules/FindPythonLibs.cmake
++++ b/Modules/FindPythonLibs.cmake
+@@ -51,7 +51,7 @@ CMAKE_FIND_FRAMEWORKS(Python)
+
+ set(_PYTHON1_VERSIONS 1.6 1.5)
+ set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
+-set(_PYTHON3_VERSIONS 3.3 3.2 3.1 3.0)
++set(_PYTHON3_VERSIONS 3.4 3.3 3.2 3.1 3.0)
+
+ if(PythonLibs_FIND_VERSION)
+ if(PythonLibs_FIND_VERSION_COUNT GREATER 1)