summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-29 00:31:12 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-29 00:31:12 +0000
commitef99176ac18796a374969ea98f9bf57dfed51e92 (patch)
treeae3fcae7e13faa705a3ba6881ae02035f160b862 /dev-util/ltrace
parentAdd systemd-timesync user/group and set gentoo default NTP servers, bug 51138... (diff)
downloadgentoo-2-ef99176ac18796a374969ea98f9bf57dfed51e92.tar.gz
gentoo-2-ef99176ac18796a374969ea98f9bf57dfed51e92.tar.bz2
gentoo-2-ef99176ac18796a374969ea98f9bf57dfed51e92.zip
Add an ebuild with Debian patches.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/ltrace')
-rw-r--r--dev-util/ltrace/ChangeLog9
-rw-r--r--dev-util/ltrace/ltrace-0.7.3_p4.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-util/ltrace/ChangeLog b/dev-util/ltrace/ChangeLog
index 2c5e97726930..610c096fa3e3 100644
--- a/dev-util/ltrace/ChangeLog
+++ b/dev-util/ltrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ltrace
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.62 2013/09/18 20:47:38 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.63 2014/05/29 00:31:12 jer Exp $
+
+*ltrace-0.7.3_p4 (29 May 2014)
+
+ 29 May 2014; Jeroen Roovers <jer@gentoo.org> +ltrace-0.7.3_p4.ebuild:
+ Add an ebuild with Debian patches.
*ltrace-0.7.3 (18 Sep 2013)
diff --git a/dev-util/ltrace/ltrace-0.7.3_p4.ebuild b/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
new file mode 100644
index 000000000000..11570b843316
--- /dev/null
+++ b/dev-util/ltrace/ltrace-0.7.3_p4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ltrace-0.7.3_p4.ebuild,v 1.1 2014/05/29 00:31:12 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+LTRACE_V=${PV/_p*/}
+DB_V=${PV/*_p/}
+
+DESCRIPTION="trace library calls made at runtime"
+HOMEPAGE="http://ltrace.alioth.debian.org/"
+SRC_URI="
+ mirror://debian/pool/main/l/${PN}/${PN}_${LTRACE_V}.orig.tar.bz2
+ mirror://debian/pool/main/l/${PN}/${PN}_${LTRACE_V}-${DB_V}.debian.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="debug selinux test unwind"
+
+RDEPEND="dev-libs/elfutils
+ selinux? ( sys-libs/libselinux )
+ unwind? ( sys-libs/libunwind )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+S=${WORKDIR}/${PN}-${LTRACE_V}
+
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/[0-9]*
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ ac_cv_header_selinux_selinux_h=$(usex selinux) \
+ ac_cv_lib_selinux_security_get_boolean_active=$(usex selinux) \
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with unwind libunwind)
+}