summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-18 03:05:38 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-18 03:05:38 +0000
commite25c0684faf1e0f6649a0862eb418dfbcd0c8371 (patch)
tree05a4357a227266a67db1fe923366e014544463e5 /dev-ruby
parentAdd ruby22 target. (diff)
downloadgentoo-2-e25c0684faf1e0f6649a0862eb418dfbcd0c8371.tar.gz
gentoo-2-e25c0684faf1e0f6649a0862eb418dfbcd0c8371.tar.bz2
gentoo-2-e25c0684faf1e0f6649a0862eb418dfbcd0c8371.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/textpow/ChangeLog9
-rw-r--r--dev-ruby/textpow/textpow-1.4.0.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-ruby/textpow/ChangeLog b/dev-ruby/textpow/ChangeLog
index 5774d77673c2..438c19f10164 100644
--- a/dev-ruby/textpow/ChangeLog
+++ b/dev-ruby/textpow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/textpow
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/textpow/ChangeLog,v 1.15 2014/08/05 16:00:33 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/textpow/ChangeLog,v 1.16 2015/01/18 03:05:38 mrueg Exp $
+
+*textpow-1.4.0 (18 Jan 2015)
+
+ 18 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +textpow-1.4.0.ebuild:
+ Version bump
05 Aug 2014; Manuel Rüger <mrueg@gentoo.org> textpow-1.3.1-r1.ebuild:
Remove trailing '.' from DESCRIPTION.
diff --git a/dev-ruby/textpow/textpow-1.4.0.ebuild b/dev-ruby/textpow/textpow-1.4.0.ebuild
new file mode 100644
index 000000000000..5ea3c4a8e9f9
--- /dev/null
+++ b/dev-ruby/textpow/textpow-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/textpow/textpow-1.4.0.ebuild,v 1.1 2015/01/18 03:05:38 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A library to parse and process Textmate bundles"
+HOMEPAGE="http://textpow.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/plist-3.0.1"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' textpow.gemspec || die
+}