summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-14 06:55:42 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-14 06:55:42 +0000
commit4ecd72e50129075e0d7e4c1126e8e9af81b7854a (patch)
treefe4fb5cda29e73119a095c2b80726794ec413b17 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-4ecd72e50129075e0d7e4c1126e8e9af81b7854a.tar.gz
gentoo-2-4ecd72e50129075e0d7e4c1126e8e9af81b7854a.tar.bz2
gentoo-2-4ecd72e50129075e0d7e4c1126e8e9af81b7854a.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/RubyInline/ChangeLog7
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.11.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/RubyInline/ChangeLog b/dev-ruby/RubyInline/ChangeLog
index 47919508ecf4..20dfb5ce7081 100644
--- a/dev-ruby/RubyInline/ChangeLog
+++ b/dev-ruby/RubyInline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/RubyInline
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.3 2012/10/28 17:21:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.4 2012/12/14 06:55:42 graaff Exp $
+
+*RubyInline-3.11.4 (14 Dec 2012)
+
+ 14 Dec 2012; Hans de Graaff <graaff@gentoo.org> +RubyInline-3.11.4.ebuild:
+ Version bump.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> RubyInline-3.8.6.ebuild:
alpha stable
diff --git a/dev-ruby/RubyInline/RubyInline-3.11.4.ebuild b/dev-ruby/RubyInline/RubyInline-3.11.4.ebuild
new file mode 100644
index 000000000000..9e51f07e9967
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.11.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/RubyInline-3.11.4.ebuild,v 1.1 2012/12/14 06:55:42 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend dev-ruby/zentest
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.11.0-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}