summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-09 11:31:59 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-09 11:31:59 +0000
commit4174ecd728f66886cc7cfb38bbe4ef6f3c632aed (patch)
treec39479bd7e0df7e0d1664ac905f6652b76388494 /dev-ruby
parentAdd ~sh (diff)
downloadgentoo-2-4174ecd728f66886cc7cfb38bbe4ef6f3c632aed.tar.gz
gentoo-2-4174ecd728f66886cc7cfb38bbe4ef6f3c632aed.tar.bz2
gentoo-2-4174ecd728f66886cc7cfb38bbe4ef6f3c632aed.zip
Don't require rubyforge to be configured. Applied patch from Fedora by Mamoru Tasaka, fixing bug 317881.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe/ChangeLog9
-rw-r--r--dev-ruby/hoe/files/hoe-2.6.0-rubyforge-without-account.patch23
-rw-r--r--dev-ruby/hoe/hoe-2.6.0-r1.ebuild34
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 35676a4a667b..521e748c729c 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.74 2010/04/26 05:29:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.75 2010/05/09 11:31:59 graaff Exp $
+
+*hoe-2.6.0-r1 (09 May 2010)
+
+ 09 May 2010; Hans de Graaff <graaff@gentoo.org> +hoe-2.6.0-r1.ebuild,
+ +files/hoe-2.6.0-rubyforge-without-account.patch:
+ Don't require rubyforge to be configured. Applied patch from Fedora by
+ Mamoru Tasaka, fixing bug 317881.
26 Apr 2010; Hans de Graaff <graaff@gentoo.org> hoe-2.6.0.ebuild:
Provide user-config file in those phases that need it. Use proper path for
diff --git a/dev-ruby/hoe/files/hoe-2.6.0-rubyforge-without-account.patch b/dev-ruby/hoe/files/hoe-2.6.0-rubyforge-without-account.patch
new file mode 100644
index 000000000000..683d44b58df7
--- /dev/null
+++ b/dev-ruby/hoe/files/hoe-2.6.0-rubyforge-without-account.patch
@@ -0,0 +1,23 @@
+--- hoe-2.6.0/lib/hoe/rubyforge.rb.account 2010-04-28 15:34:32.000000000 +0900
++++ hoe-2.6.0/lib/hoe/rubyforge.rb 2010-04-28 16:11:18.000000000 +0900
+@@ -40,12 +40,20 @@
+ end
+
+ if Hoe.plugins.include? :publish then
++ begin
+ path = File.expand_path("~/.rubyforge/user-config.yml")
+ config = YAML.load(File.read(path))
+ base = "/var/www/gforge-projects"
+ dir = "#{base}/#{rubyforge_name}/#{remote_rdoc_dir}"
+
+ rdoc_locations << "#{config["username"]}@rubyforge.org:#{dir}"
++
++ rescue Errno::ENOENT => err
++ hoe_ver = Hoe::VERSION
++ msg = err.message
++ # puts "Hoe #{hoe_ver}: warning: #{msg}"
++ end
++
+ end
+ end
+ end
diff --git a/dev-ruby/hoe/hoe-2.6.0-r1.ebuild b/dev-ruby/hoe/hoe-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..2f6e2c3b522d
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.6.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.6.0-r1.ebuild,v 1.1 2010/05/09 11:31:59 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES="${P}-rubyforge-without-account.patch"
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend test "virtual/ruby-minitest >=dev-ruby/rubyforge-2.0.3"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"