summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-19 02:52:45 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-19 02:52:45 +0000
commit42d6abbe95c3200e14ef68b0943d90451e51037d (patch)
tree3fb4968e421336e9fb6c5cd7c82ab26356d21752 /dev-ruby/json
parentbump; upstream have dropped py3.2 support and added py3.3 support (diff)
downloadgentoo-2-42d6abbe95c3200e14ef68b0943d90451e51037d.tar.gz
gentoo-2-42d6abbe95c3200e14ef68b0943d90451e51037d.tar.bz2
gentoo-2-42d6abbe95c3200e14ef68b0943d90451e51037d.zip
Cleanup old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog5
-rw-r--r--dev-ruby/json/json-1.6.8.ebuild65
2 files changed, 4 insertions, 66 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 5dd48a38614f..444b996ad4ea 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.144 2014/04/05 23:40:47 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.145 2014/04/19 02:52:45 mrueg Exp $
+
+ 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -json-1.6.8.ebuild:
+ Cleanup old.
05 Apr 2014; Manuel Rüger <mrueg@gentoo.org> json-1.6.8.ebuild,
json-1.7.7-r1.ebuild, json-1.7.7.ebuild, json-1.8.0-r1.ebuild,
diff --git a/dev-ruby/json/json-1.6.8.ebuild b/dev-ruby/json/json-1.6.8.ebuild
deleted file mode 100644
index 33de580277a3..000000000000
--- a/dev-ruby/json/json-1.6.8.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.6.8.ebuild,v 1.14 2014/04/05 23:40:47 mrueg Exp $
-
-EAPI=2
-USE_RUBY="ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e 's| => :compile||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- # Since 1.5.0 a Java extension is provided but it does not compile.
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
- fi
-}