summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-07-28 20:39:43 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-07-28 20:39:43 +0000
commite2fee8bfc26dea2253c14627165a75f8d0bbe010 (patch)
treed42b44910d074ac5c2b25860e4cb84979bb65f6a /dev-ruby/httpclient
parentVersion bump (diff)
downloadgentoo-2-e2fee8bfc26dea2253c14627165a75f8d0bbe010.tar.gz
gentoo-2-e2fee8bfc26dea2253c14627165a75f8d0bbe010.tar.bz2
gentoo-2-e2fee8bfc26dea2253c14627165a75f8d0bbe010.zip
Version bump
(Portage version: 2.1.13.1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/ChangeLog7
-rw-r--r--dev-ruby/httpclient/httpclient-2.3.4.1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 0b66a4e4d4ba..cdbcb61af910 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.46 2013/05/04 15:59:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.47 2013/07/28 20:39:43 mrueg Exp $
+
+*httpclient-2.3.4.1 (28 Jul 2013)
+
+ 28 Jul 2013; Manuel Rüger <mrueg@gentoo.org> +httpclient-2.3.4.1.ebuild:
+ Version bump
*httpclient-2.3.3 (04 May 2013)
diff --git a/dev-ruby/httpclient/httpclient-2.3.4.1.ebuild b/dev-ruby/httpclient/httpclient-2.3.4.1.ebuild
new file mode 100644
index 000000000000..d49489b616c3
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.3.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.3.4.1.ebuild,v 1.1 2013/07/28 20:39:43 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="nahi-httpclient-*"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare () {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Remove mandatory CI reports since we don't need this for testing.
+ sed -i -e '/reporter/s:^:#:' Rakefile || die
+
+ # Remove mandatory simplecov dependency
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}