summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-09 06:34:36 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-09 06:34:36 +0000
commitdd475b17a8f5f0afbe0b1095fec5f6fc1f321411 (patch)
tree2328577ad707613c11b512f1b1f8803df5ba0ddd /dev-ruby/gherkin
parentVersion bump. Cleaned up ebuild. Thanks to Torsten Kurbad and Eray Aslan. (diff)
downloadgentoo-2-dd475b17a8f5f0afbe0b1095fec5f6fc1f321411.tar.gz
gentoo-2-dd475b17a8f5f0afbe0b1095fec5f6fc1f321411.tar.bz2
gentoo-2-dd475b17a8f5f0afbe0b1095fec5f6fc1f321411.zip
Fix specs with upstream patch. Run cucumber features. Actually install documentation files.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog9
-rw-r--r--dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch29
-rw-r--r--dev-ruby/gherkin/gherkin-1.0.24-r1.ebuild39
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 4ae0990db03e..575c8e944f26 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.1 2010/05/08 08:08:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.2 2010/05/09 06:34:36 graaff Exp $
+
+*gherkin-1.0.24-r1 (09 May 2010)
+
+ 09 May 2010; Hans de Graaff <graaff@gentoo.org> +gherkin-1.0.24-r1.ebuild,
+ +files/gherkin-1.0.24-fix-specs.patch:
+ Fix specs with upstream patch. Run cucumber features. Actually install
+ documentation files.
*gherkin-1.0.24 (08 May 2010)
diff --git a/dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch b/dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch
new file mode 100644
index 000000000000..6c6cc65e9557
--- /dev/null
+++ b/dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch
@@ -0,0 +1,29 @@
+commit 20941d84343e6bf0c036fb2ae65a121e143ff334
+Author: aslakhellesoy <aslak.hellesoy@gmail.com>
+Date: Sun May 9 00:36:59 2010 +0200
+
+ Remove require of removed file. (I never saw the error because the file was found in an old gherkin gem I had installed) Closes #59
+
+diff --git a/History.txt b/History.txt
+index 7bf86c9..3755af6 100644
+--- a/History.txt
++++ b/History.txt
+@@ -1,3 +1,8 @@
++== 1.0.25 (2010-05-02)
++
++=== Bugfixes
++* Can't run specs in gherkin 1.0.24 (#59 Aslak Hellesøy)
++
+ == 1.0.24 (2010-05-02)
+
+ === Bugfixes
+diff --git a/ragel/lexer.rb.rl.erb b/ragel/lexer.rb.rl.erb
+index e600b7a..a2d26cc 100644
+--- a/ragel/lexer.rb.rl.erb
++++ b/ragel/lexer.rb.rl.erb
+@@ -1,5 +1,3 @@
+-require 'gherkin/core_ext/array'
+-
+ module Gherkin
+ module RbLexer
+ class <%= @i18n.underscored_iso_code.capitalize %> #:nodoc:
diff --git a/dev-ruby/gherkin/gherkin-1.0.24-r1.ebuild b/dev-ruby/gherkin/gherkin-1.0.24-r1.ebuild
new file mode 100644
index 000000000000..3fd7cff1edd9
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-1.0.24-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-1.0.24-r1.ebuild,v 1.1 2010/05/09 06:34:36 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="-I lib rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
+HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND} dev-util/ragel"
+
+RUBY_PATCHES="${P}-fix-specs.patch"
+
+ruby_add_bdepend test ">=dev-ruby/rspec-1.3.0 >=dev-util/cucumber-0.7.0"
+
+ruby_add_rdepend ">=dev-ruby/trollop-1.15"
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake compile
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
+}