summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-26 04:41:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-26 04:41:35 +0000
commit8617d7f995f877fbdbc365e32714ab86d75b8cae (patch)
treeea89aad545d06803e08cb0d0a53b213a73eb57ee /dev-python
parentVersion bump. Fix building with USE="doc" (bug #318757). (diff)
downloadgentoo-2-8617d7f995f877fbdbc365e32714ab86d75b8cae.tar.gz
gentoo-2-8617d7f995f877fbdbc365e32714ab86d75b8cae.tar.bz2
gentoo-2-8617d7f995f877fbdbc365e32714ab86d75b8cae.zip
Fix building with USE="doc" (bug #318759).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pastedeploy/ChangeLog8
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.3.3.ebuild38
2 files changed, 27 insertions, 19 deletions
diff --git a/dev-python/pastedeploy/ChangeLog b/dev-python/pastedeploy/ChangeLog
index 9d9b589e8c1d..0173b8c583d7 100644
--- a/dev-python/pastedeploy/ChangeLog
+++ b/dev-python/pastedeploy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pastedeploy
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.8 2009/10/11 08:27:30 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.9 2010/06/26 04:41:35 arfrever Exp $
+
+ 26 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pastedeploy-1.3.3.ebuild:
+ Fix building with USE="doc" (bug #318759).
11 Oct 2009; Fabian Groffen <grobian@gentoo.org> pastedeploy-1.3.3.ebuild:
Merge from Prefix
diff --git a/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild b/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild
index adf1a39f55bd..ff723541191c 100644
--- a/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild
+++ b/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild,v 1.6 2010/02/06 15:38:04 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild,v 1.7 2010/06/26 04:41:35 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
inherit eutils distutils multilib
@@ -22,33 +23,36 @@ IUSE="doc test"
RDEPEND=""
DEPEND="dev-python/setuptools
- doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )
- test? ( dev-python/nose dev-python/py )"
+ doc? ( dev-python/pygments dev-python/sphinx )"
RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="paste/deploy"
-src_compile() {
- distutils_src_compile
- if use doc; then
- einfo "Generating docs as requested..."
- PYTHONPATH=. "$(PYTHON -f)" setup.py pudge || die "Generation of documentation failed"
- fi
-}
+src_prepare() {
+ distutils_src_prepare
-src_test() {
# Delete broken test.
rm -f tests/test_config_middleware.py
+}
+
+src_compile() {
+ distutils_src_compile
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="." "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
}
src_install() {
distutils_src_install
- use doc && dohtml -r docs/html/*
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
}