summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-03 08:12:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-03 08:12:25 +0000
commiteeca3742835fc6a12eb4076d99acdf9b65f38945 (patch)
tree86a137d50958719621739ebaa9660e1104f4034c /dev-python/ws4py
parentBump (diff)
downloadgentoo-2-eeca3742835fc6a12eb4076d99acdf9b65f38945.tar.gz
gentoo-2-eeca3742835fc6a12eb4076d99acdf9b65f38945.tar.bz2
gentoo-2-eeca3742835fc6a12eb4076d99acdf9b65f38945.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/ChangeLog7
-rw-r--r--dev-python/ws4py/ws4py-0.3.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/ws4py/ChangeLog b/dev-python/ws4py/ChangeLog
index d32664f27c29..7e967fcf494f 100644
--- a/dev-python/ws4py/ChangeLog
+++ b/dev-python/ws4py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ws4py
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.11 2014/02/24 05:58:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.12 2014/05/03 08:12:25 patrick Exp $
+
+*ws4py-0.3.3 (03 May 2014)
+
+ 03 May 2014; Patrick Lauer <patrick@gentoo.org> +ws4py-0.3.3.ebuild:
+ Bump
*ws4py-0.3.2 (24 Feb 2014)
diff --git a/dev-python/ws4py/ws4py-0.3.3.ebuild b/dev-python/ws4py/ws4py-0.3.3.ebuild
new file mode 100644
index 000000000000..7b3f40cabab7
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.3.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.3.3.ebuild,v 1.1 2014/05/03 08:12:25 patrick Exp $
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ...
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="threads?"
+
+inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket support for Python"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+
+RDEPEND=""
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ >=dev-python/cherrypy-3.2.0[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+}