summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-02-19 13:49:22 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-02-19 13:49:22 +0000
commitf278c19e02e52c3ddfae61406bdcf38ba95efa91 (patch)
tree8d7bfa66c13cda2c464a814c85966d680cf1f830 /dev-python/twisted-web
parentadd a 12.3.0 version compatible with python-r1 (diff)
downloadgentoo-2-f278c19e02e52c3ddfae61406bdcf38ba95efa91.tar.gz
gentoo-2-f278c19e02e52c3ddfae61406bdcf38ba95efa91.tar.bz2
gentoo-2-f278c19e02e52c3ddfae61406bdcf38ba95efa91.zip
add a 12.3.0 version compatible with python-r1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/ChangeLog8
-rw-r--r--dev-python/twisted-web/twisted-web-12.3.0-r1.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index 2a588a69add7..e2a01778aa6e 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-web
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.98 2014/01/21 04:55:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.99 2014/02/19 13:49:22 ultrabug Exp $
+
+*twisted-web-12.3.0-r1 (19 Feb 2014)
+
+ 19 Feb 2014; Ultrabug <ultrabug@gentoo.org> +twisted-web-12.3.0-r1.ebuild:
+ add a 12.3.0 version compatible with python-r1 wrt dev-python/carbon
+ requirements
21 Jan 2014; Patrick Lauer <patrick@gentoo.org> -twisted-web-10.2.0.ebuild,
-twisted-web-11.0.0.ebuild, -twisted-web-11.1.0.ebuild,
diff --git a/dev-python/twisted-web/twisted-web-12.3.0-r1.ebuild b/dev-python/twisted-web/twisted-web-12.3.0-r1.ebuild
new file mode 100644
index 000000000000..13ef61839dbc
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-12.3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-12.3.0-r1.ebuild,v 1.1 2014/02/19 13:49:22 ultrabug Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit twisted-r1
+
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}