summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-05-26 06:21:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-05-26 06:21:32 +0000
commit8733bbd9fa49de69498e0e92b4731727c579da95 (patch)
treeb0458e3be368586718456998f195eed31b0c2dd3 /dev-python/twisted-web
parentBuild with LFS flags #471102. (diff)
downloadgentoo-2-8733bbd9fa49de69498e0e92b4731727c579da95.tar.gz
gentoo-2-8733bbd9fa49de69498e0e92b4731727c579da95.tar.bz2
gentoo-2-8733bbd9fa49de69498e0e92b4731727c579da95.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/ChangeLog7
-rw-r--r--dev-python/twisted-web/twisted-web-15.2.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index 1a13abe381b7..2ef8a83d93b9 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-web
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.123 2015/05/13 08:06:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.124 2015/05/26 06:21:32 patrick Exp $
+
+*twisted-web-15.2.1 (26 May 2015)
+
+ 26 May 2015; Patrick Lauer <patrick@gentoo.org> +twisted-web-15.2.1.ebuild:
+ Bump
*twisted-web-15.1.0 (13 May 2015)
diff --git a/dev-python/twisted-web/twisted-web-15.2.1.ebuild b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
new file mode 100644
index 000000000000..2c14f3cb00ca
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-15.2.1.ebuild,v 1.1 2015/05/26 06:21:32 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="TwistedWeb"
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="soap"
+
+DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed -e "s/test_forbiddenResource/_&/" -i twisted/web/test/test_static.py
+ sed -e "s/testDownloadPageError3/_&/" -i twisted/web/test/test_webclient.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+# testsuite has a PYTHONPATH oddity, currently appears to require a system install to effectively import,
+# putting in question as to whether it is a testsuite