summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-29 13:52:36 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-29 13:52:36 +0000
commitead29f5cb07bacd035c4d9709b8e45416417ead4 (patch)
tree34a9ff6835437e7882e37277cec5052f136ebb16 /dev-python/simplejson
parentinitial import from gentoo-rust overlay (diff)
downloadgentoo-2-ead29f5cb07bacd035c4d9709b8e45416417ead4.tar.gz
gentoo-2-ead29f5cb07bacd035c4d9709b8e45416417ead4.tar.bz2
gentoo-2-ead29f5cb07bacd035c4d9709b8e45416417ead4.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-3.6.3.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index fcda63e8ef4a..da977133f99f 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.133 2014/08/20 10:54:02 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.134 2014/08/29 13:52:36 radhermit Exp $
+
+*simplejson-3.6.3 (29 Aug 2014)
+
+ 29 Aug 2014; Tim Harder <radhermit@gentoo.org> +simplejson-3.6.3.ebuild:
+ Version bump.
*simplejson-3.6.2 (20 Aug 2014)
diff --git a/dev-python/simplejson/simplejson-3.6.3.ebuild b/dev-python/simplejson/simplejson-3.6.3.ebuild
new file mode 100644
index 000000000000..973c1cbb5410
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.3.ebuild,v 1.1 2014/08/29 13:52:36 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}