summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-03 18:10:45 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-03 18:10:45 +0000
commitae4f07107ca302aaa768d86cab505f834bdf43b0 (patch)
tree2fd03b021c2291e7b1a6e608a6746aa457d1208e /dev-python/scripttest
parentVersion bump tempita to 0.5.1. (diff)
downloadgentoo-2-ae4f07107ca302aaa768d86cab505f834bdf43b0.tar.gz
gentoo-2-ae4f07107ca302aaa768d86cab505f834bdf43b0.tar.bz2
gentoo-2-ae4f07107ca302aaa768d86cab505f834bdf43b0.zip
Initial version of scripttest (1.1.1).
(Portage version: 2.1.10.12/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/scripttest')
-rw-r--r--dev-python/scripttest/ChangeLog10
-rw-r--r--dev-python/scripttest/metadata.xml5
-rw-r--r--dev-python/scripttest/scripttest-1.1.1.ebuild27
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/scripttest/ChangeLog b/dev-python/scripttest/ChangeLog
new file mode 100644
index 000000000000..a0f9a5d04019
--- /dev/null
+++ b/dev-python/scripttest/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/scripttest
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scripttest/ChangeLog,v 1.1 2011/09/03 18:10:45 djc Exp $
+
+*scripttest-1.1.1 (03 Sep 2011)
+
+ 03 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> +scripttest-1.1.1.ebuild,
+ +metadata.xml:
+ Initial version 1.1.1 (for testing sqlalchemy-migrate).
+
diff --git a/dev-python/scripttest/metadata.xml b/dev-python/scripttest/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/scripttest/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/scripttest/scripttest-1.1.1.ebuild b/dev-python/scripttest/scripttest-1.1.1.ebuild
new file mode 100644
index 000000000000..177b77da7098
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scripttest/scripttest-1.1.1.ebuild,v 1.1 2011/09/03 18:10:45 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="ScriptTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="http://pythonpaste.org/scripttest/ http://pypi.python.org/pypi/ScriptTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"