summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-13 11:44:44 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-13 11:44:44 +0000
commita23afc2b81d84b018434639ab1e2b37d7627c756 (patch)
tree1082482613f8b293952161117317c5d5e9ccc508 /dev-python/qrcode
parentFix milter unit file (#495304 by Graham Murray) (diff)
downloadgentoo-2-a23afc2b81d84b018434639ab1e2b37d7627c756.tar.gz
gentoo-2-a23afc2b81d84b018434639ab1e2b37d7627c756.tar.bz2
gentoo-2-a23afc2b81d84b018434639ab1e2b37d7627c756.zip
bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/qrcode')
-rw-r--r--dev-python/qrcode/ChangeLog9
-rw-r--r--dev-python/qrcode/qrcode-4.0.4.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/qrcode/ChangeLog b/dev-python/qrcode/ChangeLog
index 0f9150a0c193..76b714c435ec 100644
--- a/dev-python/qrcode/ChangeLog
+++ b/dev-python/qrcode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/qrcode
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qrcode/ChangeLog,v 1.2 2013/09/08 09:43:42 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qrcode/ChangeLog,v 1.3 2014/04/13 11:44:44 idella4 Exp $
+
+*qrcode-4.0.4 (13 Apr 2014)
+
+ 13 Apr 2014; Ian Delaney <idella4@gentoo.org> +qrcode-4.0.4.ebuild:
+ bump
08 Sep 2013; Michał Górny <mgorny@gentoo.org> metadata.xml:
Fix pypi reference.
diff --git a/dev-python/qrcode/qrcode-4.0.4.ebuild b/dev-python/qrcode/qrcode-4.0.4.ebuild
new file mode 100644
index 000000000000..3a98e77947fa
--- /dev/null
+++ b/dev-python/qrcode/qrcode-4.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qrcode/qrcode-4.0.4.ebuild,v 1.1 2014/04/13 11:44:44 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.python.org/pypi/qrcode"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# optional deps:
+# - dev-python/lxml for svg backend
+# - virtual/pil for PIL backend
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+
+ local m=unittest
+ [[ ${EPYTHON} == python2.6 ]] && m=unittest2.__main__
+ set -- "${PYTHON}" -m ${m} qrcode.tests
+ echo "$@" >&2
+ "$@" || die "Tests failed with ${EPYTHON}"
+}