summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-09-04 03:15:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-09-04 03:15:10 +0000
commitb4b277bd568f6e4bdf080d963f70f14c8a134e22 (patch)
tree27ca3c02f36db6fda2fb48dca0036ca5959095c5 /dev-python/python-ldap
parentversion bump (diff)
downloadgentoo-2-b4b277bd568f6e4bdf080d963f70f14c8a134e22.tar.gz
gentoo-2-b4b277bd568f6e4bdf080d963f70f14c8a134e22.tar.bz2
gentoo-2-b4b277bd568f6e4bdf080d963f70f14c8a134e22.zip
Re-add python-ldap-2.3.9 as it was the last python-ldap release to support the openldap-2.3.x series. Please do NOT remove it from the tree until OpenLDAP 2.3.x is removed.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/ChangeLog7
-rw-r--r--dev-python/python-ldap/python-ldap-2.3.9.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/python-ldap/ChangeLog b/dev-python/python-ldap/ChangeLog
index 6a00243ebc71..9f02848f535d 100644
--- a/dev-python/python-ldap/ChangeLog
+++ b/dev-python/python-ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ldap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.104 2011/08/27 21:24:20 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.105 2011/09/04 03:15:10 robbat2 Exp $
+
+ 04 Sep 2011; Robin H. Johnson <robbat2@gentoo.org> +python-ldap-2.3.9.ebuild:
+ Re-add python-ldap-2.3.9 as it was the last python-ldap release to support
+ the openldap-2.3.x series. Please do NOT remove it from the tree until
+ OpenLDAP 2.3.x is removed.
27 Aug 2011; Jesus Rivero <neurogeek@gentoo.org> python-ldap-2.3.13.ebuild,
python-ldap-2.4.3.ebuild:
diff --git a/dev-python/python-ldap/python-ldap-2.3.9.ebuild b/dev-python/python-ldap/python-ldap-2.3.9.ebuild
new file mode 100644
index 000000000000..873f7318ca3d
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.3.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.3.9.ebuild,v 1.15 2011/09/04 03:15:10 robbat2 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils multilib
+
+DOC_P="${PN}-docs-html-2.3.7"
+
+DESCRIPTION="Various LDAP-related Python modules"
+HOMEPAGE="http://python-ldap.sourceforge.net/ http://pypi.python.org/pypi/python-ldap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ doc? ( http://www.python-ldap.org/doc/${DOC_P}.tar.gz )"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="doc examples sasl ssl"
+
+RDEPEND=">=net-nds/openldap-2.3
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${DEPEND}
+ dev-python/setuptools"
+
+DOCS="CHANGES README"
+PYTHON_MODNAME="dsml.py ldapurl.py ldif.py ldap"
+
+src_prepare() {
+ # Note: we can't add /usr/lib and /usr/lib/sasl2 to library_dirs due to a bug in py2.4
+ sed -e "s:^library_dirs =.*:library_dirs =:" \
+ -e "s:^include_dirs =.*:include_dirs = /usr/include /usr/include/sasl:" \
+ -e "s:\(extra_compile_args =\).*:\1\nextra_link_args = -Wl,-rpath=/usr/$(get_libdir) -Wl,-rpath=/usr/$(get_libdir)/sasl2:" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs="ldap"
+ if use sasl; then
+ use ssl && mylibs="ldap_r"
+ mylibs="${mylibs} sasl2"
+ fi
+ use ssl && mylibs="${mylibs} ssl crypto"
+
+ sed -e "s:^libs = .*:libs = lber resolv ${mylibs}:" \
+ -e "s:^compile.*:compile = 0:" \
+ -e "s:^optimize.*:optimize = 0:" \
+ -i setup.cfg || die "error setting up libs in setup.cfg"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r "${WORKDIR}/${DOC_P}"/* || die "dohtml failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r Demo || die "doins failed"
+ fi
+}