summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-16 20:57:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-16 20:57:10 +0000
commit10f88b85de5350ab2cfaa14fcf5e39480b53a6d1 (patch)
tree23b824c19550784869fda9676cc6313909987cb6 /dev-python/python-iwscan
parentAdd fbosd and macosx specific useflags (diff)
downloadgentoo-2-10f88b85de5350ab2cfaa14fcf5e39480b53a6d1.tar.gz
gentoo-2-10f88b85de5350ab2cfaa14fcf5e39480b53a6d1.tar.bz2
gentoo-2-10f88b85de5350ab2cfaa14fcf5e39480b53a6d1.zip
Fix building with >=net-wireless/wireless-tools-30_pre9 (bug #352635).
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-iwscan')
-rw-r--r--dev-python/python-iwscan/ChangeLog9
-rw-r--r--dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch14
-rw-r--r--dev-python/python-iwscan/python-iwscan-20080402.ebuild15
3 files changed, 31 insertions, 7 deletions
diff --git a/dev-python/python-iwscan/ChangeLog b/dev-python/python-iwscan/ChangeLog
index 7b70132b491d..36ecca03d916 100644
--- a/dev-python/python-iwscan/ChangeLog
+++ b/dev-python/python-iwscan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-iwscan
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/ChangeLog,v 1.12 2010/12/25 17:00:56 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/ChangeLog,v 1.13 2011/02/16 20:57:10 arfrever Exp $
+
+ 16 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-iwscan-20080402.ebuild,
+ +files/python-iwscan-20080402-wireless-tools-30.patch:
+ Fix building with >=net-wireless/wireless-tools-30_pre9 (bug #352635).
25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-iwscan-20080402.ebuild:
diff --git a/dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch b/dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch
new file mode 100644
index 000000000000..16a9dce1858f
--- /dev/null
+++ b/dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch
@@ -0,0 +1,14 @@
+--- pyiwscan.c
++++ pyiwscan.c
+@@ -13,6 +13,11 @@
+ #include <structmember.h>
+ #include <iwlib.h>
+
++/* PROC_NET_WIRELESS is defined in iwlib-private.h since wireless-tools-30_pre9 */
++#ifndef PROC_NET_WIRELESS
++#define PROC_NET_WIRELESS "/proc/net/wireless"
++#endif
++
+ #define IWSCAN_VERSION_MAJOR 0
+ #define IWSCAN_VERSION_MINOR 7
+ #define IWSCAN_VERSION_MICRO 0
diff --git a/dev-python/python-iwscan/python-iwscan-20080402.ebuild b/dev-python/python-iwscan/python-iwscan-20080402.ebuild
index 3d932d73d1ef..8c89d0241b76 100644
--- a/dev-python/python-iwscan/python-iwscan-20080402.ebuild
+++ b/dev-python/python-iwscan/python-iwscan-20080402.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/python-iwscan-20080402.ebuild,v 1.9 2010/12/25 17:00:56 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/python-iwscan-20080402.ebuild,v 1.10 2011/02/16 20:57:10 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="A Python extension for iwscan access"
HOMEPAGE="http://projects.otaku42.de/browser/python-iwscan"
@@ -18,7 +18,12 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+DEPEND="net-wireless/wireless-tools"
+RDEPEND="${DEPEND}"
PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-wireless-tools-30.patch"
+}