summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-26 00:37:33 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-26 00:37:33 +0000
commit4dd0c365b80746bde68d57a278775b3577951796 (patch)
treeb94c8a3319de17cf7eecc525b88dfb1af031a088 /dev-python/oslo-sphinx
parentDrop HPPA keywording. (diff)
downloadgentoo-2-4dd0c365b80746bde68d57a278775b3577951796.tar.gz
gentoo-2-4dd0c365b80746bde68d57a278775b3577951796.tar.bz2
gentoo-2-4dd0c365b80746bde68d57a278775b3577951796.zip
initial add of oslo.config (as oslo-config)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/oslo-sphinx')
-rw-r--r--dev-python/oslo-sphinx/ChangeLog9
-rw-r--r--dev-python/oslo-sphinx/Manifest3
-rw-r--r--dev-python/oslo-sphinx/metadata.xml13
-rw-r--r--dev-python/oslo-sphinx/oslo-sphinx-1.0.ebuild23
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/oslo-sphinx/ChangeLog b/dev-python/oslo-sphinx/ChangeLog
new file mode 100644
index 000000000000..ef1a3ee10dc5
--- /dev/null
+++ b/dev-python/oslo-sphinx/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/oslo-sphinx
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-sphinx/ChangeLog,v 1.1 2013/09/26 00:37:33 prometheanfire Exp $
+
+*oslo-sphinx-1.0 (26 Sep 2013)
+
+ 26 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> +metadata.xml,
+ +oslo-sphinx-1.0.ebuild:
+ initial add of oslo.config (as oslo-config)
diff --git a/dev-python/oslo-sphinx/Manifest b/dev-python/oslo-sphinx/Manifest
new file mode 100644
index 000000000000..43f821097d74
--- /dev/null
+++ b/dev-python/oslo-sphinx/Manifest
@@ -0,0 +1,3 @@
+DIST oslo.sphinx-1.0.tar.gz 21823 SHA256 222b76cc39ca6ed947049d348ff228cd851789827d31891dbfc61ada87704635 SHA512 fe786b1fb7072ebf72174453c0418e24679a70afc1f7674943d409a6be0ddb7386df0cdd7a402b826f5d56d42cc3087a4cf83557ae7fea2017b403a93e03f9d4 WHIRLPOOL 8b1edcd6255752d292dd55b4e5d7e61fa18de76bcb8ae04d72e34d88dc950dc97698c88753682d08967e9e83d21d1fd1f211531f69f39829d96543601b1c04d1
+EBUILD oslo-sphinx-1.0.ebuild 801 SHA256 a5c9dc8ceeb693633d4eecef051e80b269161a96430749bcda80d0f71ff152f8 SHA512 60e88986e67b27d80b6ccd6c2ce7113f95742b5d19b69cf2690ade92d615b86b8497053ee793e7539bc1a85e1efc01887d9f4cfc343d7c9f625f63ee5b42237f WHIRLPOOL 358d5928a22b0ee4d542436eee17b9e8e6ecd703d4a3275858dadf7e2431ea19274a8f79da9c567946bac1912259ec18f57d0bce755e83730be8e0bd361c2a1b
+MISC metadata.xml 405 SHA256 32b046f3eb05c77a8e414e9ebc2c39d766c8603b8fab29e603927b08b17e0b5c SHA512 cbfe2c8d26febd36675550f2e4e515a419ad3a6ec0c233df30a001e34f859795ddc1efd1d292443966c7a45c7ee837aa363bd22c8221dd0244158550cff68b74 WHIRLPOOL d550156ccab7a0828d8bd338966949d71373b9ba60dac98933f335dd92afdafd11bbfe9f2d369dab28dca89c366287f3ea6b9c7bc6245929a895b7b06ac23626
diff --git a/dev-python/oslo-sphinx/metadata.xml b/dev-python/oslo-sphinx/metadata.xml
new file mode 100644
index 000000000000..6a661672932c
--- /dev/null
+++ b/dev-python/oslo-sphinx/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Theme and extension support for Sphinx documentation from the OpenStack project.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-python/oslo-sphinx/oslo-sphinx-1.0.ebuild b/dev-python/oslo-sphinx/oslo-sphinx-1.0.ebuild
new file mode 100644
index 000000000000..994e649567ea
--- /dev/null
+++ b/dev-python/oslo-sphinx/oslo-sphinx-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-sphinx/oslo-sphinx-1.0.ebuild,v 1.1 2013/09/26 00:37:33 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Theme and extension support for Sphinx documentation from the OpenStack project."
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.sphinx/oslo.sphinx-${PV}.tar.gz"
+S="${WORKDIR}/oslo.sphinx-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.8[${PYTHON_USEDEP}] )"