summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-08 17:08:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-08 17:08:41 +0000
commitb91a2e52987837ee352010142a20ff047ccd43a7 (patch)
tree8e47139f8137bab6117c1271db33af38ff90360d /dev-python/htmlgen
parentmedia-libs/jpeg -> virtual/jpeg (diff)
downloadgentoo-2-b91a2e52987837ee352010142a20ff047ccd43a7.tar.gz
gentoo-2-b91a2e52987837ee352010142a20ff047ccd43a7.tar.bz2
gentoo-2-b91a2e52987837ee352010142a20ff047ccd43a7.zip
Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha4_p14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/htmlgen')
-rw-r--r--dev-python/htmlgen/ChangeLog8
-rw-r--r--dev-python/htmlgen/htmlgen-2.2.2.ebuild32
2 files changed, 24 insertions, 16 deletions
diff --git a/dev-python/htmlgen/ChangeLog b/dev-python/htmlgen/ChangeLog
index a57fa0958fe8..7a43bd13a21d 100644
--- a/dev-python/htmlgen/ChangeLog
+++ b/dev-python/htmlgen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/htmlgen
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/ChangeLog,v 1.12 2009/07/18 01:52:56 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/ChangeLog,v 1.13 2010/11/08 17:08:41 arfrever Exp $
+
+ 08 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ htmlgen-2.2.2.ebuild:
+ Update EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS.
18 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
htmlgen-2.2.2.ebuild, +files/htmlgen-2.2.2-python-2.5.patch:
diff --git a/dev-python/htmlgen/htmlgen-2.2.2.ebuild b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
index 03d050193e57..72df958f26e8 100644
--- a/dev-python/htmlgen/htmlgen-2.2.2.ebuild
+++ b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.15 2009/07/18 01:52:56 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.16 2010/11/08 17:08:41 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit eutils python
@@ -16,8 +19,8 @@ SLOT="0"
KEYWORDS="~amd64 ia64 ppc x86"
IUSE="doc"
-DEPEND="virtual/python
- dev-python/imaging"
+DEPEND="dev-python/imaging"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -26,18 +29,19 @@ src_prepare() {
}
src_install() {
- python_need_rebuild
-
# doing this manually because their build scripts suck
- local files="HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py \
- barchart.py colorcube.py imgsize.py NavLinks.py Formtools.py \
- ImageH.py ImageFileH.py ImagePaletteH.py GifImagePluginH.py \
+ local files="HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py
+ barchart.py colorcube.py imgsize.py NavLinks.py Formtools.py
+ ImageH.py ImageFileH.py ImagePaletteH.py GifImagePluginH.py
JpegImagePluginH.py PngImagePluginH.py"
touch __init__.py
- insinto $(python_get_sitedir)/htmlgen
- doins $files __init__.py || die "doins failed"
+ installation() {
+ insinto $(python_get_sitedir)/htmlgen
+ doins ${files} __init__.py
+ }
+ python_execute_function installation
if use doc; then
# fix the image locations in the docs
@@ -49,12 +53,12 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/htmlgen
+ python_mod_optimize htmlgen
ewarn "htmlgen now resides in its own subdirectory"
ewarn "so you need to do \"from htmlgen import HTMLgen\" instead of \"import HTMLgen\""
}
pkg_postrm () {
- python_mod_cleanup $(python_get_sitedir)/htmlgen
+ python_mod_cleanup htmlgen
}