summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-27 02:02:53 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-27 02:02:53 +0000
commit484f8990d9fef338284be4b6015a266527b1f2e8 (patch)
tree6b5b8f496e7921ea26f44561eb37c02f0041a86f /dev-python/dockerpty
parentMark m68k/s390/sh stable. (diff)
downloadgentoo-2-484f8990d9fef338284be4b6015a266527b1f2e8.tar.gz
gentoo-2-484f8990d9fef338284be4b6015a266527b1f2e8.tar.bz2
gentoo-2-484f8990d9fef338284be4b6015a266527b1f2e8.zip
add ebuild for dockerpty—dependence of fig
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/dockerpty')
-rw-r--r--dev-python/dockerpty/ChangeLog10
-rw-r--r--dev-python/dockerpty/dockerpty-0.2.4.ebuild60
-rw-r--r--dev-python/dockerpty/metadata.xml10
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/dockerpty/ChangeLog b/dev-python/dockerpty/ChangeLog
new file mode 100644
index 000000000000..34b8862ef655
--- /dev/null
+++ b/dev-python/dockerpty/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/dockerpty
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dockerpty/ChangeLog,v 1.1 2014/10/27 02:02:53 alunduil Exp $
+
+*dockerpty-0.2.4 (27 Oct 2014)
+
+ 27 Oct 2014; Alex Brandt <alunduil@gentoo.org> +dockerpty-0.2.4.ebuild,
+ +metadata.xml:
+ add ebuild written by me
+
diff --git a/dev-python/dockerpty/dockerpty-0.2.4.ebuild b/dev-python/dockerpty/dockerpty-0.2.4.ebuild
new file mode 100644
index 000000000000..5f15119bc6fd
--- /dev/null
+++ b/dev-python/dockerpty/dockerpty-0.2.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dockerpty/dockerpty-0.2.4.ebuild,v 1.1 2014/10/27 02:02:53 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/behave-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.5.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/docker-py-0.3.2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Note: https://github.com/d11wtq/dockerpty/issues/20
+ ebegin 'patching features/interactive_terminal.feature'
+ sed \
+ -e '100,119d' \
+ -i features/interactive_terminal.feature
+ STATUS=$?
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local RUN_FEATURES=0
+
+ ewarn "${PN} tests require portage to be in the docker group!"
+ getent group docker |& grep portage 1>/dev/null 2>&1
+ RUN_FEATURES+=$?
+
+ ewarn "${PN} tests require a running docker service!"
+ which docker 1>/dev/null 2>&1 && docker info 1>/dev/null 2>&1
+ RUN_FEATURES+=$?
+
+ if [[ ${RUN_FEATURES} -eq 0 ]]; then
+ behave || die "Feature tests failed under ${EPYTHON}"
+
+ fi
+
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/dockerpty/metadata.xml b/dev-python/dockerpty/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/dev-python/dockerpty/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>