summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-02-26 15:23:57 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-02-26 15:23:57 +0000
commitfef1bd06f92dacb44e7c4202f1a7177ddd643cb3 (patch)
treefbecfefd117918a4ce753023a41305dbe076bdf0 /dev-python/bitstring
parentdepend virtual/jpeg (diff)
downloadgentoo-2-fef1bd06f92dacb44e7c4202f1a7177ddd643cb3.tar.gz
gentoo-2-fef1bd06f92dacb44e7c4202f1a7177ddd643cb3.tar.bz2
gentoo-2-fef1bd06f92dacb44e7c4202f1a7177ddd643cb3.zip
Version bump
(Portage version: 2.2.0_alpha25/cvs/Linux i686)
Diffstat (limited to 'dev-python/bitstring')
-rw-r--r--dev-python/bitstring/ChangeLog9
-rw-r--r--dev-python/bitstring/bitstring-2.1.1.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/bitstring/ChangeLog b/dev-python/bitstring/ChangeLog
index 2b71cc5020ea..dde34333db6d 100644
--- a/dev-python/bitstring/ChangeLog
+++ b/dev-python/bitstring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bitstring
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bitstring/ChangeLog,v 1.2 2010/11/10 22:29:29 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bitstring/ChangeLog,v 1.3 2011/02/26 15:23:57 grozin Exp $
+
+*bitstring-2.1.1 (26 Feb 2011)
+
+ 26 Feb 2011; Andrey Grozin <grozin@gentoo.org> +bitstring-2.1.1.ebuild:
+ Version bump
10 Nov 2010; Patrick Lauer <patrick@gentoo.org> bitstring-2.0.3.ebuild:
Adding amd64 keyword for #344661
diff --git a/dev-python/bitstring/bitstring-2.1.1.ebuild b/dev-python/bitstring/bitstring-2.1.1.ebuild
new file mode 100644
index 000000000000..ae2bb7af7871
--- /dev/null
+++ b/dev-python/bitstring/bitstring-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bitstring/bitstring-2.1.1.ebuild,v 1.1 2011/02/26 15:23:57 grozin Exp $
+
+EAPI=3
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS=1
+inherit distutils
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="http://python-bitstring.googlecode.com/"
+SRC_URI="http://python-bitstring.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+
+src_test() {
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" test_${PN}.py
+ }
+ pushd test > /dev/null
+ python_execute_function testing
+ popd > /dev/null
+}