summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-01-13 02:03:51 +0000
committerMichael Orlitzky <mjo@gentoo.org>2015-01-13 02:03:51 +0000
commitc910d94c384d7f8daf3863598415dff2ac88b5d8 (patch)
treeabe14bff3a0109748326aaa94477e470f3854a09 /dev-php
parentvanilla-3.18.2 + genpatches-3.18-4 + grsecurity-3.0-3.18.2-201501120821 (diff)
downloadgentoo-2-c910d94c384d7f8daf3863598415dff2ac88b5d8.tar.gz
gentoo-2-c910d94c384d7f8daf3863598415dff2ac88b5d8.tar.bz2
gentoo-2-c910d94c384d7f8daf3863598415dff2ac88b5d8.zip
Revbump fixing LICENSE and missing RDEPEND, bug #532618.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x6F48D3DA05C2DADB!)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog10
-rw-r--r--dev-php/smarty/smarty-3.1.21-r1.ebuild48
-rw-r--r--dev-php/smarty/smarty-3.1.21.ebuild40
3 files changed, 56 insertions, 42 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index fcd81080cf37..d1d73ec7a80c 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/smarty
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.137 2014/10/29 13:56:37 grknight Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.138 2015/01/13 02:03:51 mjo Exp $
+
+*smarty-3.1.21-r1 (13 Jan 2015)
+
+ 13 Jan 2015; Michael Orlitzky <mjo@gentoo.org> +smarty-3.1.21-r1.ebuild,
+ -smarty-3.1.21.ebuild:
+ Revbump fixing LICENSE and missing RDEPEND, bug #532618.
*smarty-3.1.21 (29 Oct 2014)
diff --git a/dev-php/smarty/smarty-3.1.21-r1.ebuild b/dev-php/smarty/smarty-3.1.21-r1.ebuild
new file mode 100644
index 000000000000..d656bfdfea4f
--- /dev/null
+++ b/dev-php/smarty/smarty-3.1.21-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.1.21-r1.ebuild,v 1.1 2015/01/13 02:03:51 mjo Exp $
+
+EAPI=5
+
+MY_P="Smarty-${PV}"
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz
+ doc? ( http://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php[unicode]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ dodoc *.txt README
+ use doc && dohtml -r "${WORKDIR}/manual-en/"*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}
diff --git a/dev-php/smarty/smarty-3.1.21.ebuild b/dev-php/smarty/smarty-3.1.21.ebuild
deleted file mode 100644
index 5b5189bb67db..000000000000
--- a/dev-php/smarty/smarty-3.1.21.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.1.21.ebuild,v 1.1 2014/10/29 13:56:37 grknight Exp $
-
-EAPI=5
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-MY_P="Smarty-${PV}"
-DOC_PV="3.1.14"
-
-DESCRIPTION="A template engine for PHP"
-HOMEPAGE="http://www.smarty.net/"
-SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz
- doc? ( http://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc"
-
-DEPEND="doc? ( app-arch/unzip )"
-RDEPEND="dev-lang/php"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- insinto "/usr/share/php/${PN}"
- doins -r libs/*
-
- dodoc *.txt README
- use doc && dohtml -r "${WORKDIR}/manual-en/"*
-}
-
-pkg_postinst() {
- elog "${PN} has been installed in /usr/share/php/${PN}/."
- elog "To use it in your scripts, either"
- elog "1. define('SMARTY_DIR', \"/usr/share/php/${PN}/\") in your scripts, or"
- elog "2. add '/usr/share/php/${PN}/' to the 'include_path' variable in your"
- elog "php.ini file under /etc/php/SAPI (where SAPI is e.g apache2-php5.3,"
- elog "cgi-php5.3, etc)."
-}