summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-30 17:18:36 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-30 17:18:36 +0000
commit16c4ed27196160c047469feca50c92688bdc0e48 (patch)
tree807d5acf18caa1e738f9108d27ecca1e873c5559 /dev-php
parentRemove ancient GNU mirrors (diff)
downloadgentoo-2-16c4ed27196160c047469feca50c92688bdc0e48.tar.gz
gentoo-2-16c4ed27196160c047469feca50c92688bdc0e48.tar.bz2
gentoo-2-16c4ed27196160c047469feca50c92688bdc0e48.zip
* bump, bug #180109
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-client/ChangeLog8
-rw-r--r--dev-php/xdebug-client/files/digest-xdebug-client-2.0.0_rc43
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.0_rc4.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index ee613f9d6f51..c6e3b12f9c3c 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.3 2007/03/08 19:26:57 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.4 2007/06/30 17:18:36 voxus Exp $
+
+*xdebug-client-2.0.0_rc4 (30 Jun 2007)
+
+ 30 Jun 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +xdebug-client-2.0.0_rc4.ebuild:
+ Version bump, closing bug #180109.
*xdebug-client-2.0.0_rc3 (08 Mar 2007)
diff --git a/dev-php/xdebug-client/files/digest-xdebug-client-2.0.0_rc4 b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.0_rc4
new file mode 100644
index 000000000000..ade274eed74c
--- /dev/null
+++ b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.0_rc4
@@ -0,0 +1,3 @@
+MD5 19e614105e96741b0a030ece233a8ced xdebug-2.0.0RC4.tgz 269219
+RMD160 8d37414e3efc1aff55582781d8c2e4c4bdccfeec xdebug-2.0.0RC4.tgz 269219
+SHA256 7b4b397aa9e6f52e81ad188e42cb5332294b9748b562159edfc2b83b808eac85 xdebug-2.0.0RC4.tgz 269219
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.0_rc4.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.0_rc4.ebuild
new file mode 100644
index 000000000000..fe0539c61086
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.0.0_rc4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.0_rc4.ebuild,v 1.1 2007/06/30 17:18:36 voxus Exp $
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}/configure"
+}
+
+src_compile() {
+ econf \
+ $(use_with libedit) \
+ || die "Configure of debug client failed!"
+
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}