summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-02 23:16:27 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-02 23:16:27 +0000
commit18d4e28a278749ab564a00c6aecde8f317ef5eb9 (patch)
tree4594188a96845d8f9a7aa10665dcd372f368dd8d /dev-lisp/cl-fad
parentUnstable ppc-macos (diff)
downloadgentoo-2-18d4e28a278749ab564a00c6aecde8f317ef5eb9.tar.gz
gentoo-2-18d4e28a278749ab564a00c6aecde8f317ef5eb9.tar.bz2
gentoo-2-18d4e28a278749ab564a00c6aecde8f317ef5eb9.zip
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lisp/cl-fad')
-rw-r--r--dev-lisp/cl-fad/ChangeLog10
-rw-r--r--dev-lisp/cl-fad/Manifest3
-rw-r--r--dev-lisp/cl-fad/cl-fad-0.1.1.ebuild24
-rw-r--r--dev-lisp/cl-fad/files/digest-cl-fad-0.1.11
-rw-r--r--dev-lisp/cl-fad/metadata.xml11
5 files changed, 49 insertions, 0 deletions
diff --git a/dev-lisp/cl-fad/ChangeLog b/dev-lisp/cl-fad/ChangeLog
new file mode 100644
index 000000000000..d9626d858bc7
--- /dev/null
+++ b/dev-lisp/cl-fad/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-fad
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-fad/ChangeLog,v 1.1 2005/02/02 23:16:27 mkennedy Exp $
+
+*cl-fad-0.1.1 (02 Feb 2005)
+
+ 02 Feb 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-fad-0.1.1.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-fad/Manifest b/dev-lisp/cl-fad/Manifest
new file mode 100644
index 000000000000..00ce1513e860
--- /dev/null
+++ b/dev-lisp/cl-fad/Manifest
@@ -0,0 +1,3 @@
+MD5 4bac88f95c4f4454714da86bb3cc29cf cl-fad-0.1.1.ebuild 688
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 932864a44647d5bbb1e7ce407901fe80 files/digest-cl-fad-0.1.1 67
diff --git a/dev-lisp/cl-fad/cl-fad-0.1.1.ebuild b/dev-lisp/cl-fad/cl-fad-0.1.1.ebuild
new file mode 100644
index 000000000000..da80b9cffaf8
--- /dev/null
+++ b/dev-lisp/cl-fad/cl-fad-0.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-fad/cl-fad-0.1.1.ebuild,v 1.1 2005/02/02 23:16:27 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION='CL-FAD is a thin portability layer atop the Common Lisp standard pathname functions.'
+HOMEPAGE="http://weitz.de/cl-fad/"
+SRC_URI="mirror://gentoo/${PN}_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=cl-fad
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-fad/files/digest-cl-fad-0.1.1 b/dev-lisp/cl-fad/files/digest-cl-fad-0.1.1
new file mode 100644
index 000000000000..82e17fd68755
--- /dev/null
+++ b/dev-lisp/cl-fad/files/digest-cl-fad-0.1.1
@@ -0,0 +1 @@
+MD5 3d195b40540933924ff15b959b06293f cl-fad_0.1.1.orig.tar.gz 9348
diff --git a/dev-lisp/cl-fad/metadata.xml b/dev-lisp/cl-fad/metadata.xml
new file mode 100644
index 000000000000..1454e44186a5
--- /dev/null
+++ b/dev-lisp/cl-fad/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+CL-FAD (for "Files and Directories") is a thin layer atop Common Lisp's standard
+pathname functions. It is intended to provide some unification between current
+CL implementations on Windows, OS X, Linux, and Unix. Most of the code was
+written by Peter Seibel for his book Practical Common Lisp.
+</longdescription>
+</pkgmetadata>