summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-09-03 13:41:15 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-09-03 13:41:15 +0000
commitb4ab1120e8231a5da92747a70017c77218c1fb6a (patch)
tree715c82ca6a02566c5fca2a7f9a1b10576841bd40 /dev-libs/libev
parentApply patch to fix remote DoS in the dedicated server, bug #239557 (diff)
downloadgentoo-2-b4ab1120e8231a5da92747a70017c77218c1fb6a.tar.gz
gentoo-2-b4ab1120e8231a5da92747a70017c77218c1fb6a.tar.bz2
gentoo-2-b4ab1120e8231a5da92747a70017c77218c1fb6a.zip
Fixed dependency, bug #283558.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libev')
-rw-r--r--dev-libs/libev/ChangeLog7
-rw-r--r--dev-libs/libev/libev-3.80-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-libs/libev/ChangeLog b/dev-libs/libev/ChangeLog
index 212f969a2e69..e83ae8d0b58c 100644
--- a/dev-libs/libev/ChangeLog
+++ b/dev-libs/libev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libev
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.16 2009/08/19 16:38:41 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/ChangeLog,v 1.17 2009/09/03 13:41:15 matsuu Exp $
+
+*libev-3.80-r1 (03 Sep 2009)
+
+ 03 Sep 2009; MATSUU Takuto <matsuu@gentoo.org> +libev-3.80-r1.ebuild:
+ Fixed dependency, bug #283558.
*libev-3.80 (19 Aug 2009)
diff --git a/dev-libs/libev/libev-3.80-r1.ebuild b/dev-libs/libev/libev-3.80-r1.ebuild
new file mode 100644
index 000000000000..9ecf6d30456e
--- /dev/null
+++ b/dev-libs/libev/libev-3.80-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-3.80-r1.ebuild,v 1.1 2009/09/03 13:41:15 matsuu Exp $
+
+inherit autotools eutils
+
+MY_P="${P/0}"
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# Bug #283558
+DEPEND=">=sys-libs/glibc-2.9_p20081201"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-3.42-gentoo.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README
+}