summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-06-26 06:06:55 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-06-26 06:06:55 +0000
commit9b53b119b5c4c3679a8028e9d7a4c2902071509f (patch)
tree252d03e8c3da9bb321822da0ee23de317e30653a /dev-libs/dietlibc
parentBump 3.1rc2 -> 3.1, no source code changes (diff)
downloadgentoo-2-9b53b119b5c4c3679a8028e9d7a4c2902071509f.tar.gz
gentoo-2-9b53b119b5c4c3679a8028e9d7a4c2902071509f.tar.bz2
gentoo-2-9b53b119b5c4c3679a8028e9d7a4c2902071509f.zip
fix -nopie wrt #325539
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-libs/dietlibc')
-rw-r--r--dev-libs/dietlibc/ChangeLog10
-rw-r--r--dev-libs/dietlibc/dietlibc-0.33_pre20090721.ebuild9
-rw-r--r--dev-libs/dietlibc/dietlibc-0.33_pre20100626.ebuild50
3 files changed, 64 insertions, 5 deletions
diff --git a/dev-libs/dietlibc/ChangeLog b/dev-libs/dietlibc/ChangeLog
index b930ca0f2927..926251dfc91c 100644
--- a/dev-libs/dietlibc/ChangeLog
+++ b/dev-libs/dietlibc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/dietlibc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/ChangeLog,v 1.80 2009/08/24 15:42:30 hollow Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/ChangeLog,v 1.81 2010/06/26 06:06:55 hollow Exp $
+
+*dietlibc-0.33_pre20100626 (26 Jun 2010)
+
+ 26 Jun 2010; Benedikt Böhm <hollow@gentoo.org>
+ dietlibc-0.33_pre20090721.ebuild, +dietlibc-0.33_pre20100626.ebuild:
+ fix -nopie wrt #325539
24 Aug 2009; Benedikt Böhm <hollow@gentoo.org>
-dietlibc-0.32_pre20081116.ebuild, dietlibc-0.33_pre20090721.ebuild:
diff --git a/dev-libs/dietlibc/dietlibc-0.33_pre20090721.ebuild b/dev-libs/dietlibc/dietlibc-0.33_pre20090721.ebuild
index 83f982ebfb72..b0adc3603ad3 100644
--- a/dev-libs/dietlibc/dietlibc-0.33_pre20090721.ebuild
+++ b/dev-libs/dietlibc/dietlibc-0.33_pre20090721.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.33_pre20090721.ebuild,v 1.2 2009/08/24 15:42:30 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.33_pre20090721.ebuild,v 1.3 2010/06/26 06:06:55 hollow Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -31,7 +31,10 @@ pkg_setup() {
# Makefile does not append CFLAGS
append-flags -nostdinc -W -Wall -Wextra -Wchar-subscripts \
-Wmissing-prototypes -Wmissing-declarations -Wno-switch \
- -Wno-unused -Wredundant-decls -nopie
+ -Wno-unused -Wredundant-decls
+
+ # only use -nopie on archs that support it
+ gcc-specs-pie && append-flags -nopie
}
src_compile() {
diff --git a/dev-libs/dietlibc/dietlibc-0.33_pre20100626.ebuild b/dev-libs/dietlibc/dietlibc-0.33_pre20100626.ebuild
new file mode 100644
index 000000000000..7dcbe3233964
--- /dev/null
+++ b/dev-libs/dietlibc/dietlibc-0.33_pre20100626.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.33_pre20100626.ebuild,v 1.1 2010/06/26 06:06:55 hollow Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A minimal libc"
+HOMEPAGE="http://www.fefe.de/dietlibc/"
+SRC_URI="http://bb.xnull.de/projects/dietlibc/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+DIETHOME=/usr/diet
+
+pkg_setup() {
+ # Replace sparc64 related C[XX]FLAGS (see bug #45716)
+ use sparc && replace-sparc64-flags
+
+ # gcc-hppa suffers support for SSP, compilation will fail
+ use hppa && strip-unsupported-flags
+
+ # debug flags
+ use debug && append-flags -g
+
+ # Makefile does not append CFLAGS
+ append-flags -nostdinc -W -Wall -Wextra -Wchar-subscripts \
+ -Wmissing-prototypes -Wmissing-declarations -Wno-switch \
+ -Wno-unused -Wredundant-decls
+
+ # only use -nopie on archs that support it
+ gcc-specs-pie && append-flags -nopie
+}
+
+src_compile() {
+ emake prefix=${DIETHOME} CC="$(tc-getCC)" CFLAGS="${CFLAGS}" -j1 || die "make failed"
+}
+
+src_install() {
+ emake prefix=${DIETHOME} DESTDIR="${D}" -j1 install || die "make install failed"
+ dobin "${D}"${DIETHOME}/bin/* || die "dobin failed"
+ doman "${D}"${DIETHOME}/man/*/* || die "doman failed"
+ rm -r "${D}"${DIETHOME}/{man,bin}
+ dodoc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO PORTING
+}