summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-21 16:06:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-21 16:06:37 +0000
commit2d092a5ce75fc863968c77135fa644095555ca12 (patch)
tree0bf60221ccb0914c2a252d12cab0d43d8acaa512 /dev-lang
parentFix install directory, more fixes on translations (diff)
downloadgentoo-2-2d092a5ce75fc863968c77135fa644095555ca12.tar.gz
gentoo-2-2d092a5ce75fc863968c77135fa644095555ca12.tar.bz2
gentoo-2-2d092a5ce75fc863968c77135fa644095555ca12.zip
Bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog8
-rw-r--r--dev-lang/R/R-2.9.0.ebuild (renamed from dev-lang/R/R-2.7.1.ebuild)68
2 files changed, 38 insertions, 38 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 00203cfb74dd..8aa67d56221b 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.150 2009/04/18 15:05:11 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.151 2009/04/21 16:06:37 bicatali Exp $
+
+*R-2.9.0 (21 Apr 2009)
+
+ 21 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> -R-2.7.1.ebuild,
+ +R-2.9.0.ebuild:
+ Bump
18 Apr 2009; Markus Meier <maekke@gentoo.org> R-2.8.1:
amd64/x86 stable, bug #265338
diff --git a/dev-lang/R/R-2.7.1.ebuild b/dev-lang/R/R-2.9.0.ebuild
index 81e3898aab13..a251300ea25a 100644
--- a/dev-lang/R/R-2.7.1.ebuild
+++ b/dev-lang/R/R-2.9.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.7.1.ebuild,v 1.11 2008/10/27 10:32:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.9.0.ebuild,v 1.1 2009/04/21 16:06:37 bicatali Exp $
-inherit fortran flag-o-matic bash-completion
+EAPI=2
+inherit eutils fortran flag-o-matic bash-completion versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
HOMEPAGE="http://www.r-project.org/"
@@ -11,17 +12,18 @@ SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc java jpeg lapack minimal nls png readline tk X cairo"
+IUSE="doc java jpeg lapack minimal nls png readline threads tk X cairo"
# common depends
CDEPEND="dev-lang/perl
- >=dev-libs/libpcre-7.3
+ dev-libs/libpcre
app-arch/bzip2
virtual/blas
virtual/ghostscript
- cairo? ( x11-libs/cairo x11-libs/pango )
+ cairo? ( x11-libs/cairo[X]
+ || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
readline? ( sys-libs/readline )
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )
@@ -49,32 +51,11 @@ pkg_setup() {
export FFLAGS="${FFLAGS:--O2}"
[[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
-
- # make sure cairo and pango are both compiled with "X"
- # use flag (see bug #231970)
- if use cairo; then
- if ( ! built_with_use x11-libs/cairo X ); then
- eerror "x11-libs/cairo needs to be built with USE=\"X\""
- die "Please rebuild x11-libs/cairo with USE=\"X\""
- fi
-
- if ( ! built_with_use x11-libs/pango X ); then
- eerror "x11-libs/pango needs to be built with USE=\"X\""
- die "Please rebuild x11-libs/pango with USE=\"X\""
- fi
- fi
-
filter-ldflags -Wl,-Bdirect -Bdirect
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-javareconf.patch
- epatch "${FILESDIR}"/${P}-test-fix.patch
-}
+src_prepare() {
-src_compile() {
# fix packages.html for doc (bug #205103)
# check in later versions if fixed
sed -i \
@@ -94,8 +75,11 @@ src_compile() {
export R_BROWSER="$(type -p xdg-open)"
export R_PDFVIEWER="$(type -p xdg-open)"
fi
+}
+src_configure() {
econf \
+ --disable-rpath \
--enable-R-profiling \
--enable-memory-profiling \
--enable-R-shlib \
@@ -107,6 +91,7 @@ src_compile() {
--docdir=/usr/share/doc/${PF} \
rdocdir=/usr/share/doc/${PF} \
$(use_enable nls) \
+ $(use_enable threads) \
$(use_with lapack) \
$(use_with tk tcltk) \
$(use_with jpeg jpeglib) \
@@ -114,37 +99,46 @@ src_compile() {
$(use_with png libpng) \
$(use_with readline) \
$(use_with cairo) \
- $(use_with X x) \
- || die "econf failed"
+ $(use_with X x)
+}
+
+src_compile(){
emake || die "emake failed"
+ RMATH_V=0.0.0
+ emake -j1 -C src/nmath/standalone \
+ libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
+ || die "emake math library failed"
if use doc; then
export VARTEXFONTS="${T}/fonts"
emake info pdf || die "emake docs failed"
fi
-
- emake -j1 -C src/nmath/standalone || die "emake math library failed"
}
src_test() {
# we need to unset R_HOME otherwise some of the diff based
# tests fail due to warnings in the output
- R_HOME="" make check || die "Some of the tests failed"
+ R_HOME="" emake -j1 check || die "Some of the tests failed"
}
src_install() {
- # -j1 because creates various dirs sequentially (hit should be small)
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
if use doc; then
emake DESTDIR="${D}" \
install-info install-pdf || die "emake install docs failed"
fi
- emake -j1 \
+ emake \
-C src/nmath/standalone \
DESTDIR="${D}" install \
|| die "emake install math library failed"
+ local mv=$(get_major_version ${RMATH_V})
+ mv "${D}"/usr/$(get_libdir)/libRmath.so \
+ "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
+ dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
+ dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
+
# env file
cat > 99R <<-EOF
LDPATH=${R_HOME}/lib