summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-07-29 23:21:36 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-07-29 23:21:36 +0000
commit27e3222c1b349016b784692236bc5af629ab81b5 (patch)
tree3c37cfe5ffa8d0a4706494636be543fc857c9fcd /dev-lang
parentfixed it so that it will throw an exception on load if no selinux kernel (diff)
downloadgentoo-2-27e3222c1b349016b784692236bc5af629ab81b5.tar.gz
gentoo-2-27e3222c1b349016b784692236bc5af629ab81b5.tar.bz2
gentoo-2-27e3222c1b349016b784692236bc5af629ab81b5.zip
minor bugfix to ghc-6.0 ebuild
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/Manifest4
-rw-r--r--dev-lang/ghc/ghc-6.0.ebuild6
3 files changed, 10 insertions, 5 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 50462afa5e1f..d8f3114d4c3a 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.17 2003/07/29 11:45:10 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.18 2003/07/29 23:21:27 kosmikus Exp $
+
+ 30 Jul 2003; Andres Loeh <kosmikus@gentoo.org> ghc-6.0.ebuild:
+ Fixed bug that caused ghc to be built with HOpenGL despite -opengl being set.
29 Jul 2003; Andres Loeh <kosmikus@gentoo.org> ghc-5.04.3-r1.ebuild:
Marked 5.04.3-r1 stable. It fixes a couple of problems that keep appearing
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index 70bfe2abff44..f79f905c2f9c 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -1,10 +1,10 @@
MD5 53cadcab720c08f0d03fced644adc7ce ghc-5.04.3.ebuild 4536
MD5 e3486ab7c78862821cbbd2404db9dbfd ghc-5.04.3-r1.ebuild 6070
MD5 d1ee334700eb465393538865978531b5 ghc-5.04.ebuild 6950
-MD5 72a8b0dc85cf271c331d3508a3884c6d ghc-6.0.ebuild 4241
+MD5 b6e8ef3b1bab47650ac6a3134e931375 ghc-6.0.ebuild 4262
MD5 4e310a2cb7f0093cd85d9a366f2337cc ghc-5.04.2.ebuild 4536
MD5 42b857369c2e24507f00520e99fdaf5a ghc-5.02.3.ebuild 7646
-MD5 d3b17071bb106a3679add3571a5fb5a4 ChangeLog 4724
+MD5 563ac6caa663695b8b28da0328016cc2 ChangeLog 4870
MD5 9da9270be8ac4d92d6a5c23fd519cc3c files/lndir.c 8050
MD5 cc8947705ec2b2a685edb4eefddeebc2 files/ghc-5.02.3-gentoo.patch.bz2 14489
MD5 1c126024044290a2f7e501c0f4415169 files/ghc-5.04-gentoo.patch.bz2 68891
diff --git a/dev-lang/ghc/ghc-6.0.ebuild b/dev-lang/ghc/ghc-6.0.ebuild
index da41e7e756e6..e53c99ea8d7d 100644
--- a/dev-lang/ghc/ghc-6.0.ebuild
+++ b/dev-lang/ghc/ghc-6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.0.ebuild,v 1.1 2003/06/01 09:17:51 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.0.ebuild,v 1.2 2003/07/29 23:21:27 kosmikus Exp $
#Some explanation of bootstrap logic:
#
@@ -79,7 +79,9 @@ src_unpack() {
src_compile() {
local myconf
- myconf="`use_enable opengl hopengl`"
+ if [ `use opengl` ]; then
+ myconf="--enable-hopengl"
+ fi
# unset SGML_CATALOG_FILES because documentation installation
# breaks otherwise ...