summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-08-25 22:12:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-08-25 22:12:21 +0000
commitce4976a2af64f855b0615b09ea4774c872a11228 (patch)
treefde9beb6a36d656f37f4656e9ff89c4a793c1a25 /dev-lang/orc
parentVersion bump. (diff)
downloadgentoo-2-ce4976a2af64f855b0615b09ea4774c872a11228.tar.gz
gentoo-2-ce4976a2af64f855b0615b09ea4774c872a11228.tar.bz2
gentoo-2-ce4976a2af64f855b0615b09ea4774c872a11228.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-lang/orc')
-rw-r--r--dev-lang/orc/ChangeLog7
-rw-r--r--dev-lang/orc/orc-0.4.18.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-lang/orc/ChangeLog b/dev-lang/orc/ChangeLog
index 8e77c72b2f7a..674f9a43ad6f 100644
--- a/dev-lang/orc/ChangeLog
+++ b/dev-lang/orc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/orc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.32 2013/08/10 16:04:59 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.33 2013/08/25 22:12:21 eva Exp $
+
+*orc-0.4.18 (25 Aug 2013)
+
+ 25 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org> +orc-0.4.18.ebuild:
+ Version bump.
*orc-0.4.17-r1 (10 Aug 2013)
diff --git a/dev-lang/orc/orc-0.4.18.ebuild b/dev-lang/orc/orc-0.4.18.ebuild
new file mode 100644
index 000000000000..3e1af82e2e25
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/orc-0.4.18.ebuild,v 1.1 2013/08/25 22:12:21 eva Exp $
+
+EAPI="5"
+
+inherit autotools-multilib flag-o-matic
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="http://code.entropywave.com/projects/orc/"
+SRC_URI="http://code.entropywave.com/download/orc/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+"
+
+src_prepare() {
+ if ! use examples; then
+ sed -e '/SUBDIRS/ s:examples::' \
+ -i Makefile.am Makefile.in || die
+ fi
+}
+
+src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+ autotools-multilib_src_configure
+}