summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-02-19 13:55:59 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-02-19 13:55:59 +0000
commit9815d06a55496b689c38f11e082ac6537f4b52c2 (patch)
tree4c14bb502a5c73b0bc7ec177d26177cdb2b66fd2 /dev-java/jid3
parentadd a 12.3.0 version compatible with python-r1 (diff)
downloadgentoo-2-9815d06a55496b689c38f11e082ac6537f4b52c2.tar.gz
gentoo-2-9815d06a55496b689c38f11e082ac6537f4b52c2.tar.bz2
gentoo-2-9815d06a55496b689c38f11e082ac6537f4b52c2.zip
Revision bump. EAPI 5. Remove test? from RDEPEND. Further style fixes and cleanup of ebuild.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/jid3')
-rw-r--r--dev-java/jid3/ChangeLog11
-rw-r--r--dev-java/jid3/jid3-0.46-r2.ebuild60
2 files changed, 68 insertions, 3 deletions
diff --git a/dev-java/jid3/ChangeLog b/dev-java/jid3/ChangeLog
index 8e11fdbcf618..3dca9a05533d 100644
--- a/dev-java/jid3/ChangeLog
+++ b/dev-java/jid3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jid3
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jid3/ChangeLog,v 1.8 2008/06/12 19:13:07 serkan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jid3/ChangeLog,v 1.9 2014/02/19 13:55:59 tomwij Exp $
+
+*jid3-0.46-r2 (19 Feb 2014)
+
+ 19 Feb 2014; Tom Wijsman <TomWij@gentoo.org> +jid3-0.46-r2.ebuild:
+ Revision bump. EAPI 5. Remove test? from RDEPEND. Further style fixes and
+ cleanup of ebuild.
12 Jun 2008; Serkan Kaba <serkan@gentoo.org> -jid3-0.46.ebuild:
Remove old revision which has failing tests with several JVM's. See bug
@@ -35,4 +41,3 @@
+jid3-0.46.ebuild:
Initial addition. Fixes bug #173993. Thanks to Serkan Kaba
<serkan_kaba@yahoo.com> for the initial ebuild.
-
diff --git a/dev-java/jid3/jid3-0.46-r2.ebuild b/dev-java/jid3/jid3-0.46-r2.ebuild
new file mode 100644
index 000000000000..c3e787f90894
--- /dev/null
+++ b/dev-java/jid3/jid3-0.46-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jid3/jid3-0.46-r2.ebuild,v 1.1 2014/02/19 13:55:59 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+# To make sure the javadoc patch doesn't break things
+WANT_SPLIT_WANT="true"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="ID3 Class Library Implementation"
+HOMEPAGE="http://jid3.blinkenlights.org/"
+SRC_URI="http://jid3.blinkenlights.org/release/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+# Feel free to submit a patch that doesn't bundle the classes
+# into the result jar
+DEPEND=">=virtual/jdk-1.4
+ test? ( =dev-java/junit-3.8* )"
+
+RDEPEND=">=virtual/jre-1.4"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PV}-javadoc.patch
+ epatch "${FILESDIR}"/${PV}-tests-and-unicode.patch
+
+ rm -v "${S}"/dist/*.jar || die
+
+ if use !test; then
+ rm -rv "${S}/src/org/blinkenlights/jid3/test" || die
+ fi
+
+}
+
+src_compile() {
+ local junit="-Dlibs.junit.classpath"
+ eant jar $(use_doc) \
+ $(use test && echo ${junit}=$(java-pkg_getjars --build-only junit))
+}
+
+src_test() {
+ ejunit -cp dist/JID3.jar org.blinkenlights.jid3.test.AllTests
+}
+
+src_install() {
+ java-pkg_dojar dist/JID3.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/
+}