summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-10-16 12:56:39 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-10-16 12:56:39 +0000
commitb29056a777bb79e740edbec0570570669bcd12f0 (patch)
tree3a91b4206d8ad451763a22dfbb6b6e846c049fb1 /dev-java/istack-commons-runtime
parentRemove old revision. (diff)
downloadgentoo-2-b29056a777bb79e740edbec0570570669bcd12f0.tar.gz
gentoo-2-b29056a777bb79e740edbec0570570669bcd12f0.tar.bz2
gentoo-2-b29056a777bb79e740edbec0570570669bcd12f0.zip
Fix building with JDK 1.5. Fixes bug #289078.
(Portage version: 2.2_rc45/cvs/Linux i686)
Diffstat (limited to 'dev-java/istack-commons-runtime')
-rw-r--r--dev-java/istack-commons-runtime/ChangeLog8
-rw-r--r--dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-java/istack-commons-runtime/ChangeLog b/dev-java/istack-commons-runtime/ChangeLog
index 99b9f8db3ac7..f7e5e36fd9d6 100644
--- a/dev-java/istack-commons-runtime/ChangeLog
+++ b/dev-java/istack-commons-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/istack-commons-runtime
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/ChangeLog,v 1.9 2009/06/21 02:47:03 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/ChangeLog,v 1.10 2009/10/16 12:56:39 betelgeuse Exp $
+
+*istack-commons-runtime-20090620-r1 (16 Oct 2009)
+
+ 16 Oct 2009; Petteri Räty <betelgeuse@gentoo.org>
+ +istack-commons-runtime-20090620-r1.ebuild:
+ Fix building with JDK 1.5. Fixes bug #289078.
*istack-commons-runtime-20090620 (21 Jun 2009)
diff --git a/dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild b/dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild
new file mode 100644
index 000000000000..83d759393326
--- /dev/null
+++ b/dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/istack-commons-runtime-20090620-r1.ebuild,v 1.1 2009/10/16 12:56:39 betelgeuse Exp $
+
+JAVA_PKG_IUSE="source"
+EAPI=2
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="istack-commons"
+HOMEPAGE="https://istack-commons.dev.java.net/"
+PROJ_PN="istack-commons"
+PROJ_P="${PROJ_PN}-${PV}"
+SRC_FILE="${PROJ_P}-src.tar.bz2"
+SRC_URI="mirror://gentoo/${SRC_FILE}"
+
+LICENSE="CDDL"
+SLOT="1.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEP="
+ java-virtuals/jaf
+ java-virtuals/stax-api"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PROJ_P}"
+
+# Helper to generate the tarball :-)
+# ( PN=istack-commons-runtime ; PV=20090620 ; P="${PN}-${PV}" ; . ${P}.ebuild ; src_tarball )
+src_tarball() {
+ CVSROOT=':pserver:guest@cvs.dev.java.net:/cvs'
+ PROJ_PN='istack-commons'
+ cvs -d "${CVSROOT}" \
+ export -D $PV -d "${PROJ_P}" \
+ "${PROJ_PN}/${PROJ_PN}" && \
+ tar cvjf "${SRC_FILE}" \
+ --exclude '*.zip' \
+ --exclude '*.jar' \
+ "${PROJ_P}" \
+ && \
+ echo "New tarball located at ${SRC_FILE}"
+}
+
+java_prepare() {
+ java-ant_bsfix_one "${S}/build-common.xml"
+ java-pkg_jarfrom --into "${S}/runtime/lib" --virtual jaf
+ java-pkg_jarfrom --into "${S}/runtime/lib" --virtual stax-api
+}
+
+EANT_BUILD_XML="runtime/build.xml"
+
+src_install() {
+ java-pkg_dojar runtime/build/istack-commons-runtime.jar
+ use source && java-pkg_dosrc runtime/src/*
+}