summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-09-06 15:35:47 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-09-06 15:35:47 +0000
commitb636129cbad9b9fc49cdfcd4b58311fda1f07c22 (patch)
tree1981d6e4ec80582a6d68c1d4a5ece71cff87e649 /dev-java/dtdparser
parentStable for amd64, wrt bug #501200 (diff)
downloadgentoo-2-b636129cbad9b9fc49cdfcd4b58311fda1f07c22.tar.gz
gentoo-2-b636129cbad9b9fc49cdfcd4b58311fda1f07c22.tar.bz2
gentoo-2-b636129cbad9b9fc49cdfcd4b58311fda1f07c22.zip
Bumped to EAPI=5, dropped java-ant-2 in favor of java-pkg-simple to get rid of the buildfile patch
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/dtdparser')
-rw-r--r--dev-java/dtdparser/ChangeLog11
-rw-r--r--dev-java/dtdparser/dtdparser-1.21-r2.ebuild31
2 files changed, 39 insertions, 3 deletions
diff --git a/dev-java/dtdparser/ChangeLog b/dev-java/dtdparser/ChangeLog
index 64f928f26c47..222ba4a5343a 100644
--- a/dev-java/dtdparser/ChangeLog
+++ b/dev-java/dtdparser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/dtdparser
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/dtdparser/ChangeLog,v 1.8 2007/06/01 09:25:10 caster Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dtdparser/ChangeLog,v 1.9 2014/09/06 15:35:47 ercpe Exp $
+
+*dtdparser-1.21-r2 (06 Sep 2014)
+
+ 06 Sep 2014; Johann Schmitz <ercpe@gentoo.org> +dtdparser-1.21-r2.ebuild:
+ Bumped to EAPI=5, dropped java-ant-2 in favor of java-pkg-simple to get rid of
+ the buildfile patch
01 Jun 2007; Vlastimil Babka <caster@gentoo.org> -dtdparser-1.21.ebuild:
Gen-1 punt.
@@ -34,4 +40,3 @@
22 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org> +metadata.xml,
+files/buildfile.patch, +dtdparser-1.21.ebuild:
Initial import. Fixes #75529
-
diff --git a/dev-java/dtdparser/dtdparser-1.21-r2.ebuild b/dev-java/dtdparser/dtdparser-1.21-r2.ebuild
new file mode 100644
index 000000000000..b898d0ea7050
--- /dev/null
+++ b/dev-java/dtdparser/dtdparser-1.21-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dtdparser/dtdparser-1.21-r2.ebuild,v 1.1 2014/09/06 15:35:47 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java DTD Parser"
+HOMEPAGE="http://www.wutka.com/dtdparser.html"
+SRC_URI="http://www.wutka.com/download/${P}.tgz"
+
+LICENSE="LGPL-2.1 Apache-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}"
+
+JAVA_ENCODING="iso8859-1"
+JAVA_SRC_DIR="source"
+
+java_prepare() {
+ find -name "*.jar" -o -name "*.class" -delete || die
+ rm build.xml || die
+}