summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-05-17 21:03:54 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-05-17 21:03:54 +0000
commitaa31b5336887f8df5287bb426fc2309498174560 (patch)
treeda5432036254a8a227b841a2282213c169389036 /dev-java/commons-collections
parentTypoed test-framwork (diff)
downloadgentoo-2-aa31b5336887f8df5287bb426fc2309498174560.tar.gz
gentoo-2-aa31b5336887f8df5287bb426fc2309498174560.tar.bz2
gentoo-2-aa31b5336887f8df5287bb426fc2309498174560.zip
Add src_test support and test-framework local use flag for installing the test framework needed by commons-beanutils-collections unit tests.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/ChangeLog9
-rw-r--r--dev-java/commons-collections/commons-collections-3.2-r1.ebuild59
-rw-r--r--dev-java/commons-collections/files/digest-commons-collections-3.2-r13
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
index b3e5b8159651..0966294d5a45 100644
--- a/dev-java/commons-collections/ChangeLog
+++ b/dev-java/commons-collections/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/commons-collections
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.40 2007/02/14 22:29:28 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.41 2007/05/17 21:03:54 betelgeuse Exp $
+
+*commons-collections-3.2-r1 (17 May 2007)
+
+ 17 May 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +commons-collections-3.2-r1.ebuild:
+ Add src_test support and test-framework local use flag for installing the
+ test framework needed by commons-beanutils-collections unit tests.
14 Feb 2007; Vlastimil Babka <caster@gentoo.org>
-commons-collections-3.1.ebuild, -commons-collections-3.1-r1.ebuild:
diff --git a/dev-java/commons-collections/commons-collections-3.2-r1.ebuild b/dev-java/commons-collections/commons-collections-3.2-r1.ebuild
new file mode 100644
index 000000000000..707a398e977c
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-3.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-3.2-r1.ebuild,v 1.1 2007/05/17 21:03:54 betelgeuse Exp $
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://jakarta.apache.org/commons/collections/"
+SRC_URI="mirror://apache/jakarta/${PN/-//}/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test-framework"
+
+COMMON_DEP="test-framework? ( =dev-java/junit-3.8* )"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${P}-src"
+
+src_unpack() {
+ unpack ${A}
+ rm -v "${S}"/*.jar || die
+}
+
+src_compile() {
+ local antflags
+ if use test-framework; then
+ antflags="tf.jar -Djunit.jar=$(java-pkg_getjars junit)"
+ #no support for installing two sets of javadocs via dojavadoc atm
+ #use doc && antflags="${antflags} tf.javadoc"
+ fi
+ eant jar $(use_doc) ${antflags}
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant testjar -Djunit.jar="$(java-pkg_getjars junit)"
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+ use test-framework && \
+ java-pkg_newjar build/${PN}-testframework-3.2.jar \
+ ${PN}-testframework.jar
+
+ dodoc README.txt || die
+ java-pkg_dohtml *.html || die
+ if use doc; then
+ java-pkg_dojavadoc build/docs/apidocs
+ #use test-framework && java-pkg_dojavadoc build/docs/testframework
+ fi
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-collections/files/digest-commons-collections-3.2-r1 b/dev-java/commons-collections/files/digest-commons-collections-3.2-r1
new file mode 100644
index 000000000000..c42ac0137e38
--- /dev/null
+++ b/dev-java/commons-collections/files/digest-commons-collections-3.2-r1
@@ -0,0 +1,3 @@
+MD5 dbf80727b384bfb9c220d78af30ebc14 commons-collections-3.2-src.tar.gz 1092408
+RMD160 b6373c868159c50aab786f36c777c6e0e3395989 commons-collections-3.2-src.tar.gz 1092408
+SHA256 8a4e6339efe0c381c86956c72c8b3728288ba4ceb712d2774ea761f31b90ed6a commons-collections-3.2-src.tar.gz 1092408