summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2009-03-27 20:14:30 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2009-03-27 20:14:30 +0000
commite229c3302ac6d4a85ee4fd0495b67ea91d2d7195 (patch)
tree733ea6d4f1f49b1f006cd9a9fca021cf6f72de7a /dev-java/commons-cli
parentFix obvious typo in comments. Thanks to zlin for noticing. (diff)
downloadgentoo-2-e229c3302ac6d4a85ee4fd0495b67ea91d2d7195.tar.gz
gentoo-2-e229c3302ac6d4a85ee4fd0495b67ea91d2d7195.tar.bz2
gentoo-2-e229c3302ac6d4a85ee4fd0495b67ea91d2d7195.zip
Used EAPI2 for commons-cli and RESTRICT="test"
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'dev-java/commons-cli')
-rw-r--r--dev-java/commons-cli/commons-cli-1.2.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-java/commons-cli/commons-cli-1.2.ebuild b/dev-java/commons-cli/commons-cli-1.2.ebuild
index 6e1fa2b6a6c9..ed965440b5bf 100644
--- a/dev-java/commons-cli/commons-cli-1.2.ebuild
+++ b/dev-java/commons-cli/commons-cli-1.2.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.2.ebuild,v 1.1 2009/03/27 19:54:47 elvanor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.2.ebuild,v 1.2 2009/03/27 20:14:30 elvanor Exp $
# Upstream switched to Maven as a build system. Current build.xml file was generated by running mvn ant:ant
# A bit of tweaking was required unfortunately
+EAPI="2"
JAVA_PKG_IUSE="doc source test"
inherit java-pkg-2 java-ant-2 eutils
@@ -19,6 +20,9 @@ SLOT="1"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
+# Tests currently fail, upstream bug: https://issues.apache.org/jira/browse/CLI-178
+RESTRICT="test"
+
RDEPEND=">=virtual/jre-1.4"
# Blocking junit for https://bugs.gentoo.org/show_bug.cgi?id=215659
DEPEND=">=virtual/jdk-1.4
@@ -42,10 +46,7 @@ src_install() {
use source && java-pkg_dosrc src/java/org
}
-# Tests currently fail, upstream bug: https://issues.apache.org/jira/browse/CLI-178
-
src_test() {
- #ANT_TASKS="ant-junit"
- #eant -Djunit.present="true" test
- echo "Tests currently disabled."
+ ANT_TASKS="ant-junit"
+ eant -Djunit.present="true" test
}