summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 05:53:37 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 05:53:37 +0000
commitf9526ae42eecf0ba3600c129a637c87a78b92659 (patch)
treee37b9b02b2f18d79f3b8fd3d3414d3c15b2f46a9 /dev-haskell/crypto-pubkey
parentBump crypto-numbers to 0.2.3 (diff)
downloadgentoo-2-f9526ae42eecf0ba3600c129a637c87a78b92659.tar.gz
gentoo-2-f9526ae42eecf0ba3600c129a637c87a78b92659.tar.bz2
gentoo-2-f9526ae42eecf0ba3600c129a637c87a78b92659.zip
Bump crypto-pubkey to 0.2.3
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/crypto-pubkey')
-rw-r--r--dev-haskell/crypto-pubkey/ChangeLog7
-rw-r--r--dev-haskell/crypto-pubkey/crypto-pubkey-0.2.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-haskell/crypto-pubkey/ChangeLog b/dev-haskell/crypto-pubkey/ChangeLog
index 21dbc38e0dbc..4f59fa390418 100644
--- a/dev-haskell/crypto-pubkey/ChangeLog
+++ b/dev-haskell/crypto-pubkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/crypto-pubkey
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/ChangeLog,v 1.5 2013/11/24 19:37:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/ChangeLog,v 1.6 2013/12/11 05:53:37 gienah Exp $
+
+*crypto-pubkey-0.2.3 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +crypto-pubkey-0.2.3.ebuild:
+ Bump crypto-pubkey to 0.2.3
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> crypto-pubkey-0.2.1.ebuild:
Stable for x86, wrt bug #488750
diff --git a/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.3.ebuild b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.3.ebuild
new file mode 100644
index 000000000000..f907e8626fd9
--- /dev/null
+++ b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.3.ebuild,v 1.1 2013/12/11 05:53:37 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Public Key cryptography"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-pubkey"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmark"
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-numbers-0.2.2:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4.1:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.9.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag benchmark benchmark)
+}