summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-07-07 23:15:38 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-07-07 23:15:38 +0000
commitd338889eafb50f87a7752bd9dc47c5d52dd18949 (patch)
tree5ecc3f7226d58a3bcd8ffff7ab7143f92a837d4e /dev-db
parentRev bump to add slot dependency for dev-lang/go (diff)
downloadgentoo-2-d338889eafb50f87a7752bd9dc47c5d52dd18949.tar.gz
gentoo-2-d338889eafb50f87a7752bd9dc47c5d52dd18949.tar.bz2
gentoo-2-d338889eafb50f87a7752bd9dc47c5d52dd18949.zip
rev bump to add slot dependency on dev-lang/Go
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/etcdctl/ChangeLog7
-rw-r--r--dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-db/etcdctl/ChangeLog b/dev-db/etcdctl/ChangeLog
index 6c570894bb4d..ea13ede0872e 100644
--- a/dev-db/etcdctl/ChangeLog
+++ b/dev-db/etcdctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/etcdctl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/etcdctl/ChangeLog,v 1.3 2015/06/06 09:50:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/etcdctl/ChangeLog,v 1.4 2015/07/07 23:15:38 williamh Exp $
+
+*etcdctl-0.4.6-r1 (07 Jul 2015)
+
+ 07 Jul 2015; William Hubbs <williamh@gentoo.org> +etcdctl-0.4.6-r1.ebuild:
+ rev bump to add slot dependency on dev-lang/Go
06 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild b/dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..f825acae29f3
--- /dev/null
+++ b/dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/etcdctl/etcdctl-0.4.6-r1.ebuild,v 1.1 2015/07/07 23:15:38 williamh Exp $
+
+EAPI=5
+KEYWORDS="~amd64"
+DESCRIPTION="A simple command line client for etcd"
+HOMEPAGE="https://github.com/coreos/etcdctl/"
+SRC_URI="https://github.com/coreos/etcdctl/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=dev-lang/go-1.2:="
+RDEPEND=""
+
+src_prepare() {
+ sed -e "s:^\(go install\)\(.*\)$:\\1 -x -ldflags=\"-v -linkmode=external -extldflags '${LDFLAGS}'\" \\2:" \
+ -i build || die
+}
+
+src_compile() {
+ CGO_CFLAGS="${CFLAGS}" ./build || die
+}
+
+src_test() {
+ ./test || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+ use examples && dodoc -r examples
+}