summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-09-20 02:07:33 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-09-20 02:07:33 +0000
commit96c555b0c8e0b47a661b56f6863cdd99c4fcfd98 (patch)
treefac2ae2a3e54d6d0c4bffc8cbb086d2acd2d7e1f /dev-db/qt-unixODBC/qt-unixODBC-3.3.4-r1.ebuild
parentLicence for upcoming package "sci-chemistry/gamess". (diff)
downloadgentoo-2-96c555b0c8e0b47a661b56f6863cdd99c4fcfd98.tar.gz
gentoo-2-96c555b0c8e0b47a661b56f6863cdd99c4fcfd98.tar.bz2
gentoo-2-96c555b0c8e0b47a661b56f6863cdd99c4fcfd98.zip
Rev bump to add qt-no-rpath.patch from qt ebuild to make the portage RUNPATH error checker happy
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-db/qt-unixODBC/qt-unixODBC-3.3.4-r1.ebuild')
-rw-r--r--dev-db/qt-unixODBC/qt-unixODBC-3.3.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-db/qt-unixODBC/qt-unixODBC-3.3.4-r1.ebuild b/dev-db/qt-unixODBC/qt-unixODBC-3.3.4-r1.ebuild
new file mode 100644
index 000000000000..73fef28de44c
--- /dev/null
+++ b/dev-db/qt-unixODBC/qt-unixODBC-3.3.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/qt-unixODBC-3.3.4-r1.ebuild,v 1.1 2005/09/20 02:07:33 caleb Exp $
+
+inherit eutils
+
+SRCTYPE="free"
+DESCRIPTION="QT version ${PV}"
+HOMEPAGE="http://www.trolltech.com/"
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.bz2"
+IUSE=""
+LICENSE="|| ( QPL-1.0 GPL-2 )"
+SLOT="3"
+KEYWORDS="alpha ~amd64 ~hppa ia64 ~mips ~ppc ppc64 ~sparc ~x86"
+
+DEPEND="~x11-libs/qt-$PV
+ dev-db/unixODBC"
+
+S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+export PLATFORM=linux-g++
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/qt-no-rpath.patch
+
+
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+}
+
+src_compile() {
+ export QTDIR=${S}
+ export SYSCONF=${D}${QTBASE}/etc/settings
+
+ # Let's just allow writing to these directories during Qt emerge
+ # as it makes Qt much happier.
+ addwrite "${QTBASE}/etc/settings"
+ addwrite "$HOME/.qt"
+
+ export YACC='byacc -d'
+
+ ./configure -sm -thread -stl -system-libjpeg -verbose -largefile \
+ -qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
+ -system-libpng -lpthread -xft -platform ${PLATFORM} -xplatform \
+ ${PLATFORM} -xrender -prefix ${QTBASE} -fast ${myconf} \
+ -dlopen-opengl -plugin-sql-odbc -L${QTBASE}/lib || die
+
+ export QTDIR=${S}
+
+ cd $S/plugins/src/sqldrivers/odbc
+ emake || die
+}
+
+src_install() {
+ mkdir -p $D/$QTBASE/plugins/sqldrivers
+ cp $S/plugins/sqldrivers/libqsqlodbc.so $D/$QTBASE/plugins/sqldrivers/ || die
+}