summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-21 18:49:35 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-21 18:49:35 +0000
commitefaf84aa6e4f25c3c06a1d93b2b69d390496f938 (patch)
treecb7553b7a7f4642c6cf565c27312dc4881ba5a76 /dev-cpp/gconfmm
parentFixed USE=avahi build failure. (diff)
downloadgentoo-2-efaf84aa6e4f25c3c06a1d93b2b69d390496f938.tar.gz
gentoo-2-efaf84aa6e4f25c3c06a1d93b2b69d390496f938.tar.bz2
gentoo-2-efaf84aa6e4f25c3c06a1d93b2b69d390496f938.zip
Version bump, remove old.
(Portage version: 2.1.10.29/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gconfmm')
-rw-r--r--dev-cpp/gconfmm/ChangeLog8
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.28.2.ebuild56
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.28.3.ebuild38
3 files changed, 45 insertions, 57 deletions
diff --git a/dev-cpp/gconfmm/ChangeLog b/dev-cpp/gconfmm/ChangeLog
index 439c10905134..06d1a668a89b 100644
--- a/dev-cpp/gconfmm/ChangeLog
+++ b/dev-cpp/gconfmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/gconfmm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/ChangeLog,v 1.89 2011/10/16 17:28:26 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/ChangeLog,v 1.90 2011/10/21 18:49:35 pacho Exp $
+
+*gconfmm-2.28.3 (21 Oct 2011)
+
+ 21 Oct 2011; Pacho Ramos <pacho@gentoo.org> +gconfmm-2.28.3.ebuild,
+ -gconfmm-2.28.2.ebuild:
+ Version bump, remove old.
16 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> gconfmm-2.28.2-r1.ebuild:
ppc/ppc64 stable wrt #385699
diff --git a/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild b/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild
deleted file mode 100644
index 076c49af96f6..000000000000
--- a/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild,v 1.9 2011/03/29 06:09:12 nirbheek Exp $
-
-EAPI="1"
-
-inherit gnome2 eutils
-
-DESCRIPTION="C++ bindings for GConf"
-HOMEPAGE="http://www.gtkmm.org"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="doc examples"
-
-RDEPEND=">=gnome-base/gconf-2.4:2
- >=dev-cpp/glibmm-2.12:2
- >=dev-cpp/gtkmm-2.4:2.4"
-
-DEPEND=">=dev-util/pkgconfig-0.12.0
- ${RDEPEND}"
-
-DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
-
-src_unpack() {
- gnome2_src_unpack
-
- if ! use examples; then
- # don't waste time building the examples
- sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
- die "sed Makefile.in failed"
- fi
-}
-
-src_compile() {
- gnome2_src_compile
-
- if use doc; then
- cd "${S}/docs/reference"
- make all
- fi
-}
-
-src_install() {
- gnome2_src_install
-
- if use doc ; then
- dohtml -r docs/reference/html/* docs/images/*
- fi
-
- if use examples; then
- find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
- cp -R examples "${D}/usr/share/doc/${PF}"
- fi
-}
diff --git a/dev-cpp/gconfmm/gconfmm-2.28.3.ebuild b/dev-cpp/gconfmm/gconfmm-2.28.3.ebuild
new file mode 100644
index 000000000000..36ff1bd93fc7
--- /dev/null
+++ b/dev-cpp/gconfmm/gconfmm-2.28.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/gconfmm-2.28.3.ebuild,v 1.1 2011/10/21 18:49:35 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for GConf"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=gnome-base/gconf-2.4:2
+ >=dev-cpp/glibmm-2.12:2[doc?]
+ >=dev-cpp/gtkmm-2.4:2.4"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+pkg_setup() {
+ DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
+ G2CONF="${G2CONF}
+ $(use_enable doc documentation)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/*
+ fi
+}