summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-21 22:05:30 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-21 22:05:30 +0000
commit52dfd482d7f03064ca50caaccbb464adf905839d (patch)
tree7105d8a2dcdc38271dd26d7263b9f0972fa7582e /app-vim
parentfix test phase (diff)
downloadgentoo-2-52dfd482d7f03064ca50caaccbb464adf905839d.tar.gz
gentoo-2-52dfd482d7f03064ca50caaccbb464adf905839d.tar.bz2
gentoo-2-52dfd482d7f03064ca50caaccbb464adf905839d.zip
Version bump.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/automatictexplugin/ChangeLog7
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-12.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-vim/automatictexplugin/ChangeLog b/app-vim/automatictexplugin/ChangeLog
index 75616a221327..38782c540cfc 100644
--- a/app-vim/automatictexplugin/ChangeLog
+++ b/app-vim/automatictexplugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/automatictexplugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.34 2012/09/02 05:22:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.35 2012/09/21 22:05:30 radhermit Exp $
+
+*automatictexplugin-12 (21 Sep 2012)
+
+ 21 Sep 2012; Tim Harder <radhermit@gentoo.org> +automatictexplugin-12.ebuild:
+ Version bump.
02 Sep 2012; Tim Harder <radhermit@gentoo.org> -automatictexplugin-11.ebuild:
Remove old.
diff --git a/app-vim/automatictexplugin/automatictexplugin-12.ebuild b/app-vim/automatictexplugin/automatictexplugin-12.ebuild
new file mode 100644
index 000000000000..e3704cd2df95
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-12.ebuild,v 1.1 2012/09/21 22:05:30 radhermit Exp $
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/releases/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ >=dev-lang/python-2.7
+ dev-python/psutil
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base"