summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-11 04:57:36 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-11 04:57:36 +0000
commitf5be9f47e4146b813a51a3f20a2d14a385463a4b (patch)
treef6b28ea925c08fbcf1b9006b4333d100b30af91f /app-vim/airline
parentjust a bump of nslcd to 0.9.1 (diff)
downloadgentoo-2-f5be9f47e4146b813a51a3f20a2d14a385463a4b.tar.gz
gentoo-2-f5be9f47e4146b813a51a3f20a2d14a385463a4b.tar.bz2
gentoo-2-f5be9f47e4146b813a51a3f20a2d14a385463a4b.zip
Version bump.
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim/airline')
-rw-r--r--app-vim/airline/ChangeLog8
-rw-r--r--app-vim/airline/airline-0.5.ebuild27
-rw-r--r--app-vim/airline/airline-9999.ebuild5
3 files changed, 36 insertions, 4 deletions
diff --git a/app-vim/airline/ChangeLog b/app-vim/airline/ChangeLog
index 7fdd5684888c..e1e482cb9a0d 100644
--- a/app-vim/airline/ChangeLog
+++ b/app-vim/airline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/airline
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/airline/ChangeLog,v 1.2 2013/09/07 10:35:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/airline/ChangeLog,v 1.3 2013/09/11 04:57:36 radhermit Exp $
+
+*airline-0.5 (11 Sep 2013)
+
+ 11 Sep 2013; Tim Harder <radhermit@gentoo.org> +airline-0.5.ebuild,
+ airline-9999.ebuild:
+ Version bump.
*airline-9999 (07 Sep 2013)
diff --git a/app-vim/airline/airline-0.5.ebuild b/app-vim/airline/airline-0.5.ebuild
new file mode 100644
index 000000000000..d551982d3ef9
--- /dev/null
+++ b/app-vim/airline/airline-0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/airline/airline-0.5.ebuild,v 1.1 2013/09/11 04:57:36 radhermit Exp $
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/bling/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/bling/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/bling/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove unwanted files
+ rm -rf t Gemfile Rakefile LICENSE README*
+}
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
index a8c190325138..a16c2170a5cf 100644
--- a/app-vim/airline/airline-9999.ebuild
+++ b/app-vim/airline/airline-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/airline/airline-9999.ebuild,v 1.1 2013/09/07 10:35:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/airline/airline-9999.ebuild,v 1.2 2013/09/11 04:57:36 radhermit Exp $
EAPI=5
inherit vim-plugin
@@ -23,6 +23,5 @@ VIM_PLUGIN_HELPFILES="${PN}.txt"
src_prepare() {
# remove unwanted files
- rm LICENSE README* || die
- [[ ${PV} == 9999* ]] && rm -rf t Gemfile Rakefile
+ rm -rf t Gemfile Rakefile LICENSE README*
}