summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 17:58:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 17:58:51 +0000
commitd5670b4d37b3b0b5f018edd03a0f8ce6bd68811a (patch)
tree72f3de693b479dfc03481bee73af8b80bef65479 /app-text
parentBump to 1.4.3.2, with fixes from Attila Toth. Closes #254395 (diff)
downloadgentoo-2-d5670b4d37b3b0b5f018edd03a0f8ce6bd68811a.tar.gz
gentoo-2-d5670b4d37b3b0b5f018edd03a0f8ce6bd68811a.tar.bz2
gentoo-2-d5670b4d37b3b0b5f018edd03a0f8ce6bd68811a.zip
Bump to 2.6.12. Fixes #232587. Two patches dropped as they were accepted upstream.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/highlight/ChangeLog10
-rw-r--r--app-text/highlight/highlight-2.6.12.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index 72e0531d1535..71b896f28215 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/highlight
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.23 2008/06/19 17:04:43 ken69267 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.24 2009/02/15 17:58:51 patrick Exp $
+
+*highlight-2.6.12 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +highlight-2.6.12.ebuild:
+ Bump to 2.6.12. Fixes #232587. Two patches dropped as they were accepted
+ upstream.
19 Jun 2008; Kenneth Prugh <ken69267@gentoo.org> highlight-2.6.10.ebuild:
amd64 stable, bug #226657
diff --git a/app-text/highlight/highlight-2.6.12.ebuild b/app-text/highlight/highlight-2.6.12.ebuild
new file mode 100644
index 000000000000..ec63ed7e7b6a
--- /dev/null
+++ b/app-text/highlight/highlight-2.6.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-2.6.12.ebuild,v 1.1 2009/02/15 17:58:51 patrick Exp $
+
+WX_GTK_VER=2.6
+
+inherit wxwidgets eutils toolchain-funcs
+
+DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
+HOMEPAGE="http://www.andre-simon.de"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="wxwindows"
+
+DEPEND="wxwindows? ( =x11-libs/wxGTK-2.6* )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.6.9-gcc43.patch
+ sed -i \
+ -e "s:-O2::" \
+ -e "s:CFLAGS:CXXFLAGS:g" \
+ src/makefile || die "sed failed."
+}
+
+src_compile() {
+ emake -f makefile CXX="$(tc-getCXX)" all || die "emake all failed."
+ if use wxwindows; then
+ need-wxwidgets ansi
+ emake -f makefile CXX="$(tc-getCXX)" all-gui || die "emake all-gui failed."
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ emake -f makefile \
+ DESTDIR="${D}" \
+ install || die "emake install failed."
+ if use wxwindows; then
+ emake -f makefile \
+ DESTDIR="${D}" \
+ install-gui || die "emake install-gui failed."
+ doicon src/gui/${PN}.xpm
+ make_desktop_entry ${PN}-gui Highlight ${PN} "Utility;TextTools"
+ fi
+}