summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-15 03:24:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-15 03:24:54 +0000
commit4bcb180348021b11ba2fef021c526e4839894699 (patch)
treee9a413fae2c42eb85ab390c2ba4948090de5df63 /app-text
parentIgnore EXTRA_ECONF #379111 by Navid Zamani. (diff)
downloadgentoo-2-4bcb180348021b11ba2fef021c526e4839894699.tar.gz
gentoo-2-4bcb180348021b11ba2fef021c526e4839894699.tar.bz2
gentoo-2-4bcb180348021b11ba2fef021c526e4839894699.zip
Add a live ebuild based on my own fork of unpaper, using autotools and supporting self-tests.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/unpaper/ChangeLog10
-rw-r--r--app-text/unpaper/unpaper-9999.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/app-text/unpaper/ChangeLog b/app-text/unpaper/ChangeLog
index 5c5e7fc6080a..2154bfc3a8ad 100644
--- a/app-text/unpaper/ChangeLog
+++ b/app-text/unpaper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/unpaper
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/ChangeLog,v 1.2 2010/11/16 13:14:46 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/ChangeLog,v 1.3 2011/08/15 03:24:54 flameeyes Exp $
+
+*unpaper-9999 (15 Aug 2011)
+
+ 15 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org> +unpaper-9999.ebuild:
+ Add a live ebuild based on my own fork of unpaper, using autotools and
+ supporting self-tests.
16 Nov 2010; Christian Faulhammer <fauli@gentoo.org> unpaper-0.3.ebuild:
keyworded ~arch for x86, bug 344443
diff --git a/app-text/unpaper/unpaper-9999.ebuild b/app-text/unpaper/unpaper-9999.ebuild
new file mode 100644
index 000000000000..9c133b302048
--- /dev/null
+++ b/app-text/unpaper/unpaper-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/unpaper-9999.ebuild,v 1.1 2011/08/15 03:24:54 flameeyes Exp $
+
+EAPI=4
+EGIT_REPO_URI="git://github.com/Flameeyes/unpaper.git"
+
+inherit git-2 autotools
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="http://unpaper.berlios.de/
+ https://github.com/flameeyes/unpaper"
+
+LICENSE="GPL-2"
+
+KEYWORDS=""
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( media-libs/netpbm[png] )"
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}