summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-22 09:00:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-22 09:00:55 +0000
commitd74c0c148bfc61650c586d4cae5c32b6a71edccb (patch)
tree15add7aab14ae52a0414a7801ebcfc7f18a8050c /app-text/pelican
parentEnable installation of python module for multiple python ABIs, bug #470900 (diff)
downloadgentoo-2-d74c0c148bfc61650c586d4cae5c32b6a71edccb.tar.gz
gentoo-2-d74c0c148bfc61650c586d4cae5c32b6a71edccb.tar.bz2
gentoo-2-d74c0c148bfc61650c586d4cae5c32b6a71edccb.zip
Bump
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/ChangeLog7
-rw-r--r--app-text/pelican/pelican-3.2.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-text/pelican/ChangeLog b/app-text/pelican/ChangeLog
index 0f0ffe230c46..546a91a5ef72 100644
--- a/app-text/pelican/ChangeLog
+++ b/app-text/pelican/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pelican
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.7 2013/05/02 05:56:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.8 2013/05/22 09:00:55 patrick Exp $
+
+*pelican-3.2.1 (22 May 2013)
+
+ 22 May 2013; Patrick Lauer <patrick@gentoo.org> +pelican-3.2.1.ebuild:
+ Bump
*pelican-3.2 (02 May 2013)
diff --git a/app-text/pelican/pelican-3.2.1.ebuild b/app-text/pelican/pelican-3.2.1.ebuild
new file mode 100644
index 000000000000..c9aec7d0dd8e
--- /dev/null
+++ b/app-text/pelican/pelican-3.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/pelican-3.2.1.ebuild,v 1.1 2013/05/22 09:00:55 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files."
+HOMEPAGE="http://pelican.notmyidea.org/ http://pypi.python.org/pypi/pelican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND="dev-python/feedgenerator[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS="README.rst"
+
+python_install() {
+ distutils-r1_python_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "failed to install examples"
+ fi
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)