summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-24 07:13:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-24 07:13:44 +0000
commit3a185af28e46744706d141c2b81388504adc4b68 (patch)
treeb29289f8d289e29613e89470ad059f8a9da87a5f /app-text/pelican
parentBump (diff)
downloadgentoo-2-3a185af28e46744706d141c2b81388504adc4b68.tar.gz
gentoo-2-3a185af28e46744706d141c2b81388504adc4b68.tar.bz2
gentoo-2-3a185af28e46744706d141c2b81388504adc4b68.zip
Bump
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/ChangeLog8
-rw-r--r--app-text/pelican/pelican-3.0.ebuild43
2 files changed, 49 insertions, 2 deletions
diff --git a/app-text/pelican/ChangeLog b/app-text/pelican/ChangeLog
index 223bb2c0ead8..4ec5fce5e849 100644
--- a/app-text/pelican/ChangeLog
+++ b/app-text/pelican/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for app-text/pelican
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.1 2012/07/19 08:26:38 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.2 2012/08/24 07:13:44 patrick Exp $
+
+*pelican-3.0 (24 Aug 2012)
+
+ 24 Aug 2012; Patrick Lauer <patrick@gentoo.org> +pelican-3.0.ebuild:
+ Bump
*pelican-2.8.1 (19 Jul 2012)
19 Jul 2012; Dirkjan Ochtman <djc@gentoo.org> +pelican-2.8.1.ebuild,
+metadata.xml:
Initial version of pelican (bug 379671).
-
diff --git a/app-text/pelican/pelican-3.0.ebuild b/app-text/pelican/pelican-3.0.ebuild
new file mode 100644
index 000000000000..29c97a710d62
--- /dev/null
+++ b/app-text/pelican/pelican-3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/pelican-3.0.ebuild,v 1.1 2012/08/24 07:13:44 patrick Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files."
+HOMEPAGE="http://pelican.notmyidea.org/ http://pypi.python.org/pypi/pelican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND="dev-python/feedgenerator
+ dev-python/jinja
+ dev-python/docutils
+ dev-python/pygments
+ dev-python/pytz
+ dev-python/unidecode
+ dev-python/blinker
+ markdown? ( dev-python/markdown )
+ || ( dev-lang/python:2.7 dev-python/argparse )"
+RDEPEND=""
+
+DOCS="README.rst"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "failed to install examples"
+ fi
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)